Closed Bug 1558658 Opened 1 year ago Closed 8 months ago

Fingerprinting Blocking and Tracking protection breaks social media gallery embeds provided by gleam.io

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: englehardt, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Example site: https://www.lootcrate.com/community

See the attached image for a comparison. This breakage is caused by the blocking of js.gleam.io, which is classified both as a Fingerprinter and a Tracker.

Summary: Fingerprinting Blocking and Tracking protection breaks social media gallery embeds provided by glean.io → Fingerprinting Blocking and Tracking protection breaks social media gallery embeds provided by gleam.io
Flags: needinfo?(senglehardt)
Priority: -- → P3
Flags: needinfo?(senglehardt)
Duplicate of this bug: 1558659

This breakage was resolved by Gleam migrating their anti-fraud fingerprinting code over to a new domain (i.e., fraudjs.io). See https://github.com/disconnectme/disconnect-tracking-protection/commit/a0403914453915e600719c75846e1594f1cbb0c0.

The fraudjs.io domain is currently only on content-fingerprinting-track-digest256 (meaning it is not currently blocked by Firefox's fingerprinting blocking), but will be added to base-fingerprinting-track-digest256 once https://github.com/disconnectme/disconnect-tracking-protection/commit/f4099a5d0913f96c340a95f94f72c5238562bbb2 is merged into Firefox's lists.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.