Closed Bug 1558870 Opened 5 months ago Closed 5 months ago

Extend telemetry for WebAuthn / U2F

Categories

(Core :: DOM: Web Authentication, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: jcj, Assigned: jcj)

References

Details

(Whiteboard: [webauthn])

Attachments

(2 files)

Telemetry for WebAuthn is currently marked to expire in Firefox 70, but let's move that out about another year to 78 since adoption is only now getting underway.

Attachment #9071663 - Flags: data-review?(chutten)
Comment on attachment 9071663 [details]
Data Collection Review.md

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is Telemetry so is documented in its definitions files [Histograms.json](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Histograms.json) and [Scalars.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Scalars.yaml) and the [Probe Dictionary](https://telemetry.mozilla.org/probe-dictionary/).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire in Firefox 78.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. :jcj is responsible for renewing or removing the collection before it expires in Firefox 78.

---
Result: datareview+
Attachment #9071663 - Flags: data-review?(chutten) → data-review+
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3f8e247b1056
Extend WebAuthn Telemetry to release 78. r=KevinJacobs
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1553175
You need to log in before you can comment on or make changes to this bug.