Closed Bug 1558882 Opened 3 months ago Closed 3 months ago

OSX Mojave (10.14) - ThreadMetrics.CollectMetrics | Expected: (duration) < (200000u), actual: 278857 vs 200000 @ /builds/worker/workspace/build/src/xpcom/tests/gtest/TestThreadMetrics.cpp:153

Categories

(Core :: XPCOM, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: tarek)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=251074328&repo=try
Full log: https://queue.taskcluster.net/v1/task/MSgzLG2BQAa3UuzSunBogw/runs/0/artifacts/public/logs/live_backing.log


Platform: macosx1014-mojave

Context:
02:15:56 INFO - TEST-START | ThreadMetrics.CollectMetrics
02:15:56 WARNING - TEST-UNEXPECTED-FAIL | ThreadMetrics.CollectMetrics | Expected: (duration) < (200000u), actual: 278857 vs 200000 @ /builds/worker/workspace/build/src/xpcom/tests/gtest/TestThreadMetrics.cpp:153
02:15:56 WARNING - TEST-UNEXPECTED-FAIL | ThreadMetrics.CollectMetrics | test completed (time: 279ms)

:froydnj - this appears to be a new failure observed on macosx1014, and only on shippable-opt. Would you be able to take a look, or pass the ni to someone that may be able to comment, thanks!

Summary: Intermittent ThreadMetrics.CollectMetrics | Expected: (duration) < (200000u), actual: 278857 vs 200000 @ /builds/worker/workspace/build/src/xpcom/tests/gtest/TestThreadMetrics.cpp:153 → OSX Mojave (10.14) - ThreadMetrics.CollectMetrics | Expected: (duration) < (200000u), actual: 278857 vs 200000 @ /builds/worker/workspace/build/src/xpcom/tests/gtest/TestThreadMetrics.cpp:153

Tarek it looks like you're most knowledgeable about these tests, can you take a look at this?

Flags: needinfo?(tarek)

On it

Assignee: nobody → tarek
Flags: needinfo?(tarek)

The first test does not really need to check that we spend less than
200ms, and we can give more time to the scheduler in the second
test, as long as we check that is less than the recursive dispatched
event

Pushed by tziade@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12d826365c0c
Fixed intermittent on ThreadMetrics.CollectMetrics r=erahm
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

I believe we're migrating 68 to 10.14 as well in support of the next ESR, so a=test-only for uplifting this fix there as well.

Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.