Closed Bug 1559168 Opened 3 years ago Closed 3 years ago

`mach browsertime --setup` needs to set +x on installed binaries

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1559727

People

(Reporter: nalexander, Assigned: nalexander)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(7 obsolete files)

We have reports of folks not being able to execute ffmpeg, convert, compare, etc, especially on macOS. It looks like we need to set +x ourselves; either the archives don't contain the bit, or it's being dropped by the unpacking flow.

Attachment #9087524 - Attachment is obsolete: true
Attachment #9087556 - Attachment is obsolete: true
Attachment #9087556 - Attachment is obsolete: false
Attachment #9087564 - Attachment is obsolete: true
Attachment #9087496 - Attachment is obsolete: true
Attachment #9087556 - Attachment is obsolete: true

Sorry (again) for all the Phabricator ticket creations, and accompanying spam; this should be ready for testing and review (in that order), over in https://phabricator.services.mozilla.com/D43152.

Nick, feel free to assign this to me, so the email spam can largely be mine :-)

Flags: needinfo?(nalexander)
Attachment #9087496 - Attachment is obsolete: false
Attachment #9087556 - Attachment is obsolete: false
Attachment #9087564 - Attachment is obsolete: false
Attachment #9087496 - Attachment is obsolete: true
Attachment #9087564 - Attachment is obsolete: true
Attachment #9087565 - Attachment is obsolete: true
Attachment #9087580 - Attachment is obsolete: true
Attachment #9087556 - Attachment is obsolete: true

I'm happy to report that :sparky has a fix for this and other issues over in bug 1559727. I haven't been actively working on this for a while (sorry!) Greg, did you want to take this, or should we just mark it as a duplicate (since it ultimately is?)

Flags: needinfo?(gmierz2)
Attachment #9087588 - Attachment is obsolete: true

Yup, let's resolve it as a duplicate.

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gmierz2)
Resolution: --- → DUPLICATE
Duplicate of bug: 1559727

Thx; verified.

Status: RESOLVED → VERIFIED
Flags: needinfo?(nalexander)
Has Regression Range: --- → yes
Keywords: regression
You need to log in before you can comment on or make changes to this bug.