Closed Bug 1559243 Opened 1 year ago Closed 1 year ago

[AS only] After disabling Pocket section in via about:prefererences, Pocket section can't be re-enabled until restart

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.3 - Jun 10 - 23
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 + fixed
firefox69 --- verified

People

(Reporter: k88hudson, Assigned: pdahiya)

References

(Regression)

Details

(Keywords: github-merged, regression)

Attachments

(2 files)

With discovery stream disabled:

  1. Go to about:preferences#home and disable the Pocket section
  2. Verify Pocket is gone from the new tab page
  3. Re-enable pocket on about:preferences#home

Actual: Pocket is still missing from the new tab page until a restart
Expected: Pocket is visible on the new tab page

This regression was introduced somewhere in Firefox 68.

Reverting bug 1544578 fixes the problem. This only affects de locale 68 beta users right now

Regressed by: 1544578

German users won't be able to turn pocket back on until restart

Assignee: nobody → pdahiya
Iteration: --- → 69.3 - Jun 10 - 23
Priority: -- → P1
Blocks: 1559536
Status: NEW → RESOLVED
Closed: 1 year ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

The issue is no longer reproducible on the latest Nightly 69.0a1 (Build ID 20190619095537) on Windows 10, macOS 10.14, and Arch Linux 4.14.3.

Status: RESOLVED → VERIFIED

Comment on attachment 9072749 [details]
Bug 1559243 - [AS only] After disabling Pocket section in via about:prefererences, Pocket section can't be re-enabled until restart

Beta/Release Uplift Approval Request

  • User impact if declined: German users turning off pocket new tab section won't see it turn back on until restarting firefox
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Restores existing behavior by partially reverting the regressing bug 1544578
  • String changes made/needed: none
Attachment #9072749 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9072749 [details]
Bug 1559243 - [AS only] After disabling Pocket section in via about:prefererences, Pocket section can't be re-enabled until restart

AS fix for 68.0b12

Attachment #9072749 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.