Closed Bug 1559412 Opened 6 months ago Closed 4 months ago

Support web app manifest ImageResource.purpose

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

69 Branch
Unspecified
All
enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: tigeroakes, Assigned: marcosc)

Details

(Whiteboard: [geckoview:fenix:p2])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

A parsed web app manifest should include all properties for ImageResources in the icons field

Actual results:

"purpose" is stripped out from ImageResource entries

Expected results:

The ImageObjectProcessor class only keeps the "src", "type", and "sizes" attributes from entries in the "icons" array in a web app manifest. A-C needs access to the "purpose" field as well, which determines if an icon can be masked and used as an adaptive icon.

https://www.w3.org/TR/appmanifest/#purpose-member
https://searchfox.org/mozilla-central/source/dom/manifest/ImageObjectProcessor.jsm#69

Assignee: nobody → mislam
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Marcos, just a heads up, in case you have opinions: the A-C team would like to access ImageResource's purpose field for Fenix. Maliha is an intern working with the A-C team.

Component: General → DOM: Core & HTML
Flags: needinfo?(mcaceres)
Product: GeckoView → Core
Whiteboard: [geckoview:fenix:p2]

Thanks for the heads-up, Chris!

Maliha, happy to review or help however I can. I'm marcosc on Slack if you have any questions.

Flags: needinfo?(mcaceres)
Priority: -- → P2
Assignee: mislam → mcaceres

implementation of purpose member

Type: defect → enhancement
Pushed by mcaceres@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90d0473fe6aa
Support web app manifest ImageResource.purpose r=baku
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

firefox69=wontfix because we don't need to uplift this web app manifest changes to GV 69 Beta (especially considering it adds new dom.properties strings that need to be translated).

You need to log in before you can comment on or make changes to this bug.