Closed Bug 1559512 Opened 5 months ago Closed 4 months ago

Intermittent dom/media/tests/mochitest/test_peerConnection_basicVideoVerifyRtpHeaderExtensions.html | number of sdp ids match received ids ["3","4","5"] == ["5","4"]

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bwc)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=251947623&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/YkFOtTEcTzSGLCBy8aYTwQ/runs/0/artifacts/public/logs/live_backing.log


20:34:44 INFO - TEST-PASS | dom/media/tests/mochitest/test_peerConnection_basicVideoVerifyRtpHeaderExtensions.html | RTP flowing for video track {54faa72f-ce40-b147-85dd-fce567f7ed01}
20:34:44 INFO - Checking for stats in [["outbound_rtp_video_0",{"id":"outbound_rtp_video_0","timestamp":1560544484138,"type":"outbound-rtp","kind":"video","mediaType":"video","ssrc":480811336,"bytesSent":3859,"packetsSent":13,"bitrateMean":0,"bitrateStdDev":0,"droppedFrames":0,"firCount":0,"framerateMean":0,"framerateStdDev":0,"framesEncoded":0,"nackCount":0,"pliCount":0,"remoteId":""}],["pPzR",{"id":"pPzR","timestamp":1560544484138,"type":"candidate-pair","bytesReceived":3412,"bytesSent":5045,"componentId":1,"lastPacketReceivedTimestamp":1560544484129,"lastPacketSentTimestamp":1560544484138,"localCandidateId":"1t4B","nominated":true,"priority":7962083765675491000,"readable":true,"remoteCandidateId":"Kvy/","selected":true,"state":"succeeded","transportId":"transport_0","writable":true}],["1t4B",{"id":"1t4B","timestamp":1560544484138,"type":"local-candidate","address":"10.49.56.29","candidateType":"host","port":59816,"priority":2122252543,"protocol":"udp"}],["aGRH",{"id":"aGRH","timestamp":1560544484138,"type":"local-candidate","address":"10.49.56.29","candidateType":"host","port":64567,"priority":2105524479,"protocol":"tcp"}],["Kvy/",{"id":"Kvy/","timestamp":1560544484138,"type":"remote-candidate","address":"10.49.56.29","candidateType":"prflx","port":54069,"priority":1853817087,"protocol":"udp"}]] for video track {7c7d0b06-e3fe-c849-8a2f-a7f33c7634e3}retry number 1
20:34:44 INFO - Should have RTP stats for track {7c7d0b06-e3fe-c849-8a2f-a7f33c7634e3}
20:34:44 INFO - RTP stats: {"id":"outbound_rtp_video_0","timestamp":1560544484138,"type":"outbound-rtp","kind":"video","mediaType":"video","ssrc":480811336,"bytesSent":3859,"packetsSent":13,"bitrateMean":0,"bitrateStdDev":0,"droppedFrames":0,"firCount":0,"framerateMean":0,"framerateStdDev":0,"framesEncoded":0,"nackCount":0,"pliCount":0,"remoteId":""}
20:34:44 INFO - Track {7c7d0b06-e3fe-c849-8a2f-a7f33c7634e3} has 13 outbound-rtp RTP packets.
20:34:44 INFO - TEST-PASS | dom/media/tests/mochitest/test_peerConnection_basicVideoVerifyRtpHeaderExtensions.html | RTP flowing for video track {7c7d0b06-e3fe-c849-8a2f-a7f33c7634e3}
20:34:44 INFO - Run step 38: PC_REMOTE_CHECK_RTP_HEADER_EXTS_AGAINST_SDP
20:34:44 INFO - Buffered messages finished
20:34:44 INFO - TEST-UNEXPECTED-FAIL | dom/media/tests/mochitest/test_peerConnection_basicVideoVerifyRtpHeaderExtensions.html | number of sdp ids match received ids ["3","4","5"] == ["5","4"]
20:34:44 INFO - sdp = v=0
20:34:44 INFO - o=mozilla...THIS_IS_SDPARTA-69.0a1 6498733361172091192 0 IN IP4 0.0.0.0
20:34:44 INFO - s=-
20:34:44 INFO - t=0 0
20:34:44 INFO - a=fingerprint:sha-256 CD:C5:9A:4D:A2:EA:24:44:35:99:1C:89:EE:F9:62:37:A2:04:BE:E6:F4:27:12:94:74:36:41:94:30:6D:10:72
20:34:44 INFO - a=group:BUNDLE 0
20:34:44 INFO - a=ice-options:trickle
20:34:44 INFO - a=msid-semantic:WMS *
20:34:44 INFO - m=video 9 UDP/TLS/RTP/SAVPF 120 121 126 97
20:34:44 INFO - c=IN IP4 0.0.0.0
20:34:44 INFO - a=sendrecv
20:34:44 INFO - a=extmap:3 urn:ietf:params:rtp-hdrext:sdes:mid
20:34:44 INFO - a=extmap:4 http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time
20:34:44 INFO - a=extmap:5 urn:ietf:params:rtp-hdrext:toffset
20:34:44 INFO - a=fmtp:126 profile-level-id=42e01f;level-asymmetry-allowed=1;packetization-mode=1
20:34:44 INFO - a=fmtp:97 profile-level-id=42e01f;level-asymmetry-allowed=1
20:34:44 INFO - a=fmtp:120 max-fs=12288;max-fr=60
20:34:44 INFO - a=fmtp:121 max-fs=12288;max-fr=60
20:34:44 INFO - a=ice-pwd:4bc9b4c2d8b4f0f7501c83acd1373707
20:34:44 INFO - a=ice-ufrag:7617676b
20:34:44 INFO - a=mid:0
20:34:44 INFO - a=msid:{7bcf5710-d1fd-fe48-a5ff-7d06643e9f78} {7bf1fec2-d05d-1c4d-b73c-dd09ab65aa0d}
20:34:44 INFO - a=rtcp-fb:120 nack
20:34:44 INFO - a=rtcp-fb:120 nack pli
20:34:44 INFO - a=rtcp-fb:120 ccm fir
20:34:44 INFO - a=rtcp-fb:120 goog-remb
20:34:44 INFO - a=rtcp-fb:121 nack

It looks like this test is failing because the sdes:mid RTP extension is not present in the RTP packet the test grabs. But, that's not totally unexpected; the mid extension only goes in the first several RTP packets, after which the receiver should have established what ssrc corresponds to that mid. We probably need to grab this RTP packet earlier, as soon as possible.

Assignee: nobody → docfaraday

Try looks ok, besides the instances of bug 1541424 and bug 1541587.

Attachment #9077713 - Attachment description: Bug 1559512: (WIP) Make sure that we grab the first RTP packet when checking RTP extensions, because the mid extension is only used in the first several. → Bug 1559512: Make sure that we grab the first RTP packet when checking RTP extensions, because the mid extension is only used in the first several. r?jib
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a2529d7cdc6
Make sure that we grab the first RTP packet when checking RTP extensions, because the mid extension is only used in the first several. r=jib
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
See Also: → 1419011

Comment on attachment 9077713 [details]
Bug 1559512: Make sure that we grab the first RTP packet when checking RTP extensions, because the mid extension is only used in the first several. r?jib

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Intermittent failure fix.
  • User impact if declined:
  • Fix Landed on Version: 70, 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky. Just a change to a test-case.
  • String or UUID changes made by this patch: None
Attachment #9077713 - Flags: approval-mozilla-esr68?
Duplicate of this bug: 1419011

Comment on attachment 9077713 [details]
Bug 1559512: Make sure that we grab the first RTP packet when checking RTP extensions, because the mid extension is only used in the first several. r?jib

This is test-only and can land without approval.

Attachment #9077713 - Flags: approval-mozilla-esr68?
You need to log in before you can comment on or make changes to this bug.