Closed Bug 1559664 Opened 2 years ago Closed 2 years ago

Evaluate if doubleClickSelectsAll has still the right default behavior on more recent Linux

Categories

(Firefox :: Address Bar, defect, P5)

All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 333714
Tracking Status
firefox69 --- affected

People

(Reporter: violet.bugreport, Unassigned)

Details

STR:

  1. Type multiple words in the address bar for searching. e.g. "Lorem ipsum dolor sit amet"

  2. User wants to modify the single word "dolor" in the middle. They double click the "dolor".

Expected result:

The single word "dolor" is selected.

Actual result:

The whole sentence is selected.

NOTE: double-click word selection works everywhere in Firefox, and in pretty much every other browser/app. It's weird that it doesn't work in address bar.

Summary: Double-click word selection now working in address bar → Double-click word selection not working in address bar

This works for me on the latest nightly build on Mac. Please could you provide some more details about your Firefox version and Operating system.

Flags: needinfo?(violet.bugreport)

I can reproduce it on my Ubuntu 18.04 with current Nightly and Beta (I don't have stable release installed).

However, I just tried it on my Mac, it worked fine.

Flags: needinfo?(violet.bugreport)
OS: Unspecified → Linux

Try changing browser.urlbar.doubleClickSelectsAll in about:config

(In reply to Marco Bonardo [::mak] from comment #3)

Try changing browser.urlbar.doubleClickSelectsAll in about:config

Thanks, this pref solves the problem.

However, I'm wondering why this pref is set to true by default? It seems to be a very unintuitive behavior for users. I personally haven't encountered any other places where double click doesn't select a word.

afaik it's how things are supposed to work on Linux, for consistency with other urlbars (not sure if we should re-evaluate the choice for "modern" linux)

(In reply to Marco Bonardo [::mak] from comment #5)

for consistency with other urlbars

At least double click on Chrome urlbar also selects the word, not the sentence. I'm not aware of other apps with a urlbar though.

As I said, the decision was made 13 years ago in bug 190615 and at the time it was consistent with other similar apps; clearly as any other thing we can re-evaluate after a so long time if our default is still good for users.

Priority: -- → P5
Hardware: Unspecified → All
Summary: Double-click word selection not working in address bar → Evaluate if doubleCklickSelectsAll has still the right default behavior on more recent Linux
Summary: Evaluate if doubleCklickSelectsAll has still the right default behavior on more recent Linux → Evaluate if doubleClickSelectsAll has still the right default behavior on more recent Linux
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333714
You need to log in before you can comment on or make changes to this bug.