Closed Bug 1560268 Opened 3 years ago Closed 3 years ago

Categories

(Core :: CSS Parsing and Computation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: impossibus)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=252510221&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/es9VvBJ4SCOdpkmHLvsamA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/es9VvBJ4SCOdpkmHLvsamA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-06-19T22:59:25.179Z] 22:59:25 INFO - TEST-START | /css/css-contain/contain-size-flexbox-001.html
[task 2019-06-19T22:59:26.211Z] 22:59:26 INFO - TEST-PASS | /css/css-contain/contain-size-flexbox-001.html | took 1034ms
[task 2019-06-19T22:59:26.212Z] 22:59:26 INFO - TEST-START | /css/css-contain/contain-size-flexbox-002.html
[task 2019-06-19T22:59:27.293Z] 22:59:27 INFO - TEST-UNEXPECTED-FAIL | /css/css-contain/contain-size-flexbox-002.html | Testing http://web-platform.test:8000/css/css-contain/contain-size-flexbox-002.html == http://web-platform.test:8000/css/css-contain/reference/contain-size-flexbox-002-ref.html
[task 2019-06-19T22:59:27.293Z] 22:59:27 INFO - REFTEST IMAGE 1 (TEST):
[task 2019-06-19T22:59:27.293Z] 22:59:27 INFO - REFTEST IMAGE 2 (REFERENCE):
[task 2019-06-19T22:59:27.293Z] 22:59:27 INFO - TEST-INFO took 1076ms
[task 2019-06-19T22:59:28.021Z] 22:59:28 INFO - Closing logging queue
[task 2019-06-19T22:59:28.021Z] 22:59:28 INFO - queue closed
[task 2019-06-19T22:59:28.037Z] 22:59:28 INFO - Setting android reftest preferences
[task 2019-06-19T22:59:28.037Z] 22:59:28 INFO - Setting up ssl
[task 2019-06-19T22:59:28.052Z] 22:59:28 INFO - certutil |
[task 2019-06-19T22:59:28.068Z] 22:59:28 INFO - certutil |
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO - certutil |
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO - Certificate Nickname Trust Attributes
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO - SSL,S/MIME,JAR/XPI
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO -
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO - web-platform-tests CT,,
[task 2019-06-19T22:59:28.075Z] 22:59:28 INFO -
[task 2019-06-19T22:59:29.796Z] 22:59:29 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-06-19T22:59:31.248Z] 22:59:31 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_PROCESS_LOG=/tmp/tmpnKVQJNpidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --ez use_multiprocess True --es env10 R_LOG_LEVEL=6
[task 2019-06-19T22:59:33.197Z] 22:59:33 INFO - Starting runner
[task 2019-06-19T22:59:34.175Z] 22:59:34 INFO - TEST-START | /css/css-contain/contain-size-grid-001.html
[task 2019-06-19T22:59:35.123Z] 22:59:35 INFO - TEST-PASS | /css/css-contain/contain-size-grid-001.html | took 948ms
[task 2019-06-19T22:59:35.123Z] 22:59:35 INFO - TEST-START | /css/css-contain/contain-size-grid-002.html
[task 2019-06-19T22:59:35.652Z] 22:59:35 INFO - TEST-FAIL | /css/css-contain/contain-size-grid-002.html | took 530ms
[task 2019-06-19T22:59:35.653Z] 22:59:35 INFO - TEST-START | /css/css-contain/contain-size-monolithic-001.html

Pretty sure this just needs a metadata update.

Flags: needinfo?(wkocher) → needinfo?(mjzffr)
Flags: needinfo?(mjzffr)

Yeah, this seems to be a test that fails in Android, and I think that's a bug in the test assumptions. I think it has to do with the fact that scrollbars on Android take up no space, and that baseline-alignment is different between scrollable flex (in the testcase) vs. scrollable block (in the reference case).

I'll spin off a separate bug to look into this in more detail and fix the test if needed.

See Also: → 1560420
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/aebef74ae4cf
Update metadata for /css/css-contain/contain-size-flexbox-002.html; r=whimboo

Backed out for perma fails on testrunner.py.

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&selectedJob=253339664&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=aebef74ae4cf423ccc5b0a53a84584f3f839c7f4

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=253339664&repo=autoland&lineNumber=41824

14:44:06 INFO - PID 9488 | [Parent 10080, Main Thread] WARNING: 'error.Failed()', file z:/build/build/src/dom/ipc/JSWindowActor.cpp, line 171
14:44:06 INFO - PID 9488 | JavaScript error: , line 0: NS_ERROR_UNEXPECTED:
14:44:06 INFO - PID 9488 | 1561473846469 Marionette INFO No differences allowed
14:44:06 ERROR - Traceback (most recent call last):
14:44:06 ERROR - File "Z:\task_1561469447\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testrunner.py", line 371, in run
14:44:06 ERROR - new_state = self.wait_event()
14:44:06 ERROR - File "Z:\task_1561469447\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testrunner.py", line 446, in wait_event
14:44:06 ERROR - return f(*data)
14:44:06 ERROR - File "Z:\task_1561469447\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testrunner.py", line 612, in test_ended
14:44:06 ERROR - stack=file_result.stack)
14:44:06 ERROR - File "Z:\task_1561469447\build\venv\lib\site-packages\mozlog\logtypes.py", line 58, in inner
14:44:06 ERROR - data = converter.convert(*args, **kwargs)
14:44:06 ERROR - File "Z:\task_1561469447\build\venv\lib\site-packages\mozlog\logtypes.py", line 99, in convert
14:44:06 ERROR - out_value = self.argskey
14:44:06 ERROR - File "Z:\task_1561469447\build\venv\lib\site-packages\mozlog\logtypes.py", line 138, in call
14:44:06 ERROR - (value, type(value).name, self.name, self.class.name))
14:44:06 ERROR - ValueError: Failed to convert value bug:1560268 of type unicode for field expected to type Status
14:44:06 ERROR -
14:44:06 INFO - Browser exited with return code 572
14:44:06 INFO - PROCESS LEAKS c:\users\task_1561469447\appdata\local\temp\tmpdp1plz.mozrunner\runtests_leaks_9452.log
14:44:06 INFO - leakcheck | Processing log file c:\users\task_1561469447\appdata\local\temp\tmpdp1plz.mozrunner\runtests_leaks_9452.log for scope /css/css-contain
14:44:06 INFO - TEST-INFO | leakcheck | default process: leak threshold set at 0 bytes
14:44:06 INFO - TEST-INFO | leakcheck | plugin process: leak threshold set at 0 bytes
14:44:06 INFO - TEST-INFO | leakcheck | tab process: leak threshold set at 10000 bytes
14:44:06 INFO - TEST-INFO | leakcheck | gmplugin process: leak threshold set at 20000 bytes
14:44:06 INFO - TEST-INFO | leakcheck | gpu process: leak threshold set at 0 bytes
14:44:06 INFO - TEST-INFO | leakcheck | rdd process: leak threshold set at 400 bytes
14:44:06 INFO - TEST-INFO | leakcheck | vr process: leak threshold set at 0 bytes
14:44:06 INFO - TEST-INFO | leakcheck | socket process: leak threshold set at 0 bytes
14:44:06 INFO - leakcheck | Processing leak log file c:\users\task_1561469447\appdata\local\temp\tmpdp1plz.mozrunner\runtests_leaks_9452.log
14:44:06 INFO - TEST-UNEXPECTED-FAIL | leakcheck | default missing output line for total leaks!

Backout: https://hg.mozilla.org/integration/autoland/rev/2ea10485a26c8667d6ce0dbc4abda83cbad38d52

Flags: needinfo?(mjzffr)
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/74bb6796032d
Update metadata for /css/css-contain/contain-size-flexbox-002.html; r=whimboo
Flags: needinfo?(mjzffr)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → mjzffr
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.