Closed Bug 1560425 Opened 6 months ago Closed 5 months ago

Remove old performance measurement API

Categories

(Core :: JavaScript Engine, defect, P1)

All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: gkw, Assigned: mgaudet)

References

Details

Attachments

(1 file)

As per f2f conversation with :mgaudet and :jorendorff, let's consider removing code in js/src/perf (Performance Measurement API).

See also bug 583322, bug 583323, bug 642516 and bug 683138 when this gets resolved.

I discovered that js/src/perf code is not being tested well in CovManager, and was wondering how it can be tested better, when it was mentioned that the code should probably be removed instead.

Flags: needinfo?(mgaudet)
Type: task → defect
Flags: needinfo?(mgaudet)
Blocks: 1356043
Priority: -- → P1
Pushed by mgaudet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c01ea1369f01
Remove old performance measurement API r=jorendorff
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1356043
You need to log in before you can comment on or make changes to this bug.