URL in Finder info missing

VERIFIED DUPLICATE of bug 90918

Status

Core Graveyard
File Handling
--
enhancement
VERIFIED DUPLICATE of bug 90918
16 years ago
2 years ago

People

(Reporter: Jean-Pierre Melkonian, Assigned: Bill Law)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a+) Gecko/20020705
BuildID:    2002070508

In Netscape 4.x there was a cool feature: The Original URL of a dowloaded or
saved file was written in the finder "Info" Field of the file

Reproducible: Always
Steps to Reproduce:
1.Download a file
2.Select it By the Finder
3."Show Info"

Actual Results:  Nothing is displayed in the Info field

Expected Results:  Original URL displayed
-> File Handling
Assignee: Matti → law
Component: Browser-General → File Handling
QA Contact: asa → sairuh

Comment 2

16 years ago
This feature would be a useful addition to Mozilla.

This feature has been part of iCab, the Mac only web browser, for a couple of
years now.

An even better version of this feature would be to insert the URL of downloaded
document as a html comment into the start of the html source. This is already
done by the UNIX web browser client Lynx as a configuration option. This way the
URL is permanently associated with the file. If the URL is only pasted into the
Comments field of the GetInfo window then this will be lost if the Desktop
Datebase is deleted.

Comment 3

16 years ago
Note that if you drag the icon from the locationbar to the desktop, you create
an alias on the desktop. In it's info-window, you can see the 'address' field
with the URL.

I know it's not the same, but this code could be easily reused when creating a file.

Comment 4

16 years ago
I was looking for the code which create the URL-field for the aliases, but I
couldn't find it. Then I found
http://developer.apple.com/technotes/tn/pdf/tn1142.pdf (chapter "Internet
Location Files and Clipping Files") and
http://bugzilla.mozilla.org/show_bug.cgi?id=122041#c9

I think we can do this by attaching a 'url ' resource with id #256, but that
might only work for 'ilht' files (the clipping file). I don't know if that would
work for another filetype (depends on the Finder actually). I'll try tonight,
both on MacOS 9 and MacOS X.

(Reporter)

Comment 5

16 years ago
The Finder info is not deleted after a rebuild, if you use a
standard way.
(Personally i never use the standard way, but it is my problem)
Adding the URL in the HTML Code, is not a good idea:
  1- it is usable only with HTML files
  2- Every body does not read HTML Code, so you have to ADD a feature in Mozilla
     to show the Original URL
  3- Some http Servers send text/html for a binary file (hqx files for examples)
     The file Is still usable for decompression.
     Adding a Comment corrupts the File
     More generally, i Think that modifying the Original file is not a
     good thing

I use this field, generally to restart an interrupted download
 - By the browser, without surfing through the visited paged and entering a lot   
   of information in a download form
 - Or pasting it in my FTP Client, which is more reliable than a browser.


I don't need to keep this URL permanently. If i need that, i bookmark it.
But if you find a way to keep it, permanently, go on...

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 90918 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Url in Finder info missing → URL in Finder info missing
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.