Closed Bug 1561215 Opened 6 months ago Closed 5 months ago

Webrender clips viewport with Responsive Design Mode meta viewport on

Categories

(Core :: Graphics: WebRender, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 + wontfix
firefox70 + verified

People

(Reporter: rares.doghi, Assigned: botond)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
Nightly 69.0a1

[Affected platforms]:
Platforms: ALL

Prerequisites:
Access FF and enter in about:config
Type devtools.responsive.metaViewport.enabled and set the value to "true"
Type gfx.webrender.all set to "true" and verify about:support for Composition (Webrender)

Steps :

  1. Launch the Firefox browser and reach www.facebook.com and zoom to 150%
  2. Hit Ctrl + Shift + M in order to start Responsive Design Mode.
  3. Enable touch Simulation.

Expected Results :
The page should be displayed properly with touch simulation enabled.

Actual Results :
The page seems cropped in RDM mode.

Notes:
With Webrender ON and Viewport ON this issue can be reproduced as soon as the user enables touch simulation in RDM.
With Webrender Off and Viewport ON or Viceversa this issue does not reproduce.

Please also note that on some Systems where Webrender is unsupported and the Composition just says Basic The issue occurs when the user Exits RDM not when RDM is on.

Attached image 2019-06-25_10h07_41.png

This will need attention from the WebRender team.

Component: Responsive Design Mode → Graphics: WebRender
Product: DevTools → Core
Summary: The RDM viewport does not display websites properly with Webrender on → Webrender clips viewport with Responsive Design Mode meta viewport on

This will probably be fixed by the same thing that fixes bug 1520096.

Component: Graphics: WebRender → Layout
Depends on: 1520096

This was regressed by bug 1558106.

Keywords: regression
Regressions: 1558106
Regressed by: 1558106
No longer regressions: 1558106

The regressor landed in 69 and 68 is marked as unaffected, so 67 should be unaffected.

See Also: → 1563717

The priority flag is not set for this bug.
:dholbert, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dholbert)

This seems to be in the wrong component. Someone from the WebRender team should triage.

Component: Layout → Graphics: WebRender
Flags: needinfo?(dholbert)
Priority: -- → P3
Blocks: wr-69

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

assigning to Botond for now since it looks like this will be fixed by: bug 1563717

Assignee: nobody → botond

Confirmed this was fixed by bug 1563717.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

This issue still occurs When the user Exits RDM, I have also left a comment on Bug 1563717 so we can keep a better track of this issue. Please let us know if we should log a new issue for it. I'll attach the current behavior here as well.

Flags: needinfo?(botond)
Attached image 2019-07-29_10h51_36.png

Can you please open a new bug for the issue?

Target Milestone: --- → mozilla70

This issue is Verified as Fixed in Nightly 70.0a1 (2019-07-29) based on the steps from the Description.

I have added a new issue Bug 1569626 as requested in Comment 14.

See Also: → 1569626
Flags: needinfo?(botond)

Since This is a wontfix for 69 we can update the flags accordingly.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.