Closed Bug 1561249 Opened 5 months ago Closed 5 months ago

No WPT catching extraneous MediaStream events "active" and "inactive" and related handler attributes

Categories

(Core :: WebRTC: Audio/Video, task, P3)

67 Branch
task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: pehrsons, Assigned: pehrsons)

References

Details

Attachments

(1 file)

Bug 1560969 removed a dependency on the "inactive" event from WPT, since it's no longer part of the spec. Chrome was passing that test, but there appears to be nothing catching it in WPT.

I had thought the idlharness would, but it appears to only test that things in the idl are present in the objects, not that there's nothing more present.

Assignee: nobody → apehrson
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f7b92e4c05a9
Check that MediaStream's onactive and oninactive attributes are not supported in WPT. r=jib
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

This doesn't seem to have made it to the WPT repo. James, do you know what's up?

Flags: needinfo?(james)
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17704 for changes under testing/web-platform/tests
Upstream PR merged

The bot got stuck and I was away. Seems to be fixed now (and we plan to have more people able to sort out this kind of thing in the future).

Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.