Closed Bug 1561313 Opened 2 years ago Closed 2 years ago

23.37 - 81.69% raptor-tp6-yahoo-news-firefox regression on push 2f0eee5a985db0e1aa41e33918b2e3cd4da34e3f (Mon June 24 2019)

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Bebe, Unassigned)

References

(Regression)

Details

(Keywords: perf, regression)

Raptor has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=2f0eee5a985db0e1aa41e33918b2e3cd4da34e3f

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

82% raptor-tp6-yahoo-news-firefox loadtime windows7-32-shippable opt 324.29 -> 589.21
77% raptor-tp6-yahoo-news-firefox loadtime windows10-64-shippable opt 329.79 -> 583.33
77% raptor-tp6-yahoo-news-firefox loadtime windows10-64-shippable-qr opt 331.62 -> 585.38
61% raptor-tp6-yahoo-news-firefox loadtime linux64-shippable opt 359.33 -> 578.58
60% raptor-tp6-yahoo-news-firefox loadtime linux64-shippable-qr opt 374.08 -> 600.33
59% raptor-tp6-yahoo-news-firefox loadtime macosx1014-64-shippable opt 684.12 -> 1,088.25
54% raptor-tp6-yahoo-news-firefox windows7-32-shippable opt 242.98 -> 374.00
51% raptor-tp6-yahoo-news-firefox windows10-64-shippable opt 246.88 -> 373.20
51% raptor-tp6-yahoo-news-firefox windows10-64-shippable-qr opt 248.78 -> 375.04
42% raptor-tp6-yahoo-news-firefox fcp windows7-32-shippable opt 236.38 -> 336.12
41% raptor-tp6-yahoo-news-firefox macosx1014-64-shippable opt 492.55 -> 692.47
40% raptor-tp6-yahoo-news-firefox fcp windows10-64-shippable opt 239.79 -> 336.88
40% raptor-tp6-yahoo-news-firefox fcp windows10-64-shippable-qr opt 242.29 -> 339.12
34% raptor-tp6-yahoo-news-firefox linux64-shippable opt 277.87 -> 372.56
33% raptor-tp6-yahoo-news-firefox linux64-shippable-qr opt 289.06 -> 385.42
32% raptor-tp6-yahoo-news-firefox fcp macosx1014-64-shippable opt 461.50 -> 607.33
24% raptor-tp6-yahoo-news-firefox fcp linux64-shippable opt 269.83 -> 335.50
23% raptor-tp6-yahoo-news-firefox fcp linux64-shippable-qr opt 280.62 -> 346.21

Improvements:

47% raptor-tp6-reddit-firefox loadtime macosx1014-64-shippable opt 5,097.46 -> 2,682.83
23% raptor-tp6-reddit-firefox loadtime linux64-shippable-qr opt 1,974.96 -> 1,511.29
23% raptor-tp6-reddit-firefox loadtime windows10-64-shippable opt 2,052.08 -> 1,570.96
23% raptor-tp6-reddit-firefox loadtime windows10-64-shippable-qr opt 2,019.79 -> 1,554.58
23% raptor-tp6-reddit-firefox fcp windows7-32-shippable opt 296.46 -> 229.50
22% raptor-tp6-reddit-firefox fcp windows10-64-shippable-qr opt 277.12 -> 216.96
21% raptor-tp6-reddit-firefox macosx1014-64-shippable opt 1,121.98 -> 887.03
20% raptor-tp6-reddit-firefox macosx1014-64-shippable opt 1,117.19 -> 892.10
20% raptor-tp6-reddit-firefox loadtime linux64-shippable opt 1,842.42 -> 1,474.17
20% raptor-tp6-reddit-firefox fcp windows10-64-shippable opt 280.54 -> 225.54
18% raptor-tp6-reddit-firefox fcp macosx1014-64-shippable opt 531.23 -> 433.50
18% raptor-tp6-reddit-firefox fcp linux64-shippable-qr opt 265.04 -> 216.54
15% raptor-tp6-reddit-firefox fcp linux64-shippable opt 255.50 -> 217.00
13% raptor-tp6-reddit-firefox windows10-64-shippable-qr opt 567.52 -> 496.27
12% raptor-tp6-reddit-firefox windows10-64-shippable opt 571.31 -> 503.34
12% raptor-tp6-reddit-firefox linux64-shippable-qr opt 550.49 -> 486.06
10% raptor-tp6-reddit-firefox linux64-shippable opt 527.41 -> 475.22

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=21582

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a Treeherder page showing the Raptor jobs in a pushlog format.

To learn more about the regressing test(s) or reproducing them, please see: https://wiki.mozilla.org/Performance_sheriffing/Raptor

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Priority: -- → P1

:bebe can you follow up on this (or associate the re-record bug if that's the cause) thanks!

Flags: needinfo?(fstrugariu)

These are re-recordings regressions from bugs 1559937, 1559939

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(fstrugariu)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.