Cannot delete several messages at once

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: beanladen, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 1.1a Linux i386:

1. Send a couple of messages to yourself
2. select one
3. try to select several messages with SHIFT-LEFT mouse
    ==> several mail windows pop up with each message in one window

Expected: Highlight selected messages for further operations like 'delete'

The mechanism seems to work correctly if I have displayed all messages
before by clicking on them. 
This is a regression from 1.0, where it worked correctly.

Updated

16 years ago
QA Contact: olgam → gchan

Comment 1

16 years ago
reporter,
I believe this is a dupe of bug 150716.

In 1.1a builds, selecting multiple mesgs for moving/deletion
was broken. If you get a more current build (after 6/14 is when
the fix for 150716 went in), your problem should be solved.

marking as dupe of bug 150716.


*** This bug has been marked as a duplicate of 150716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Oh !

I missed that this has been duplicated to a totally unrelated issue!
Please read the bug you are duplicating to before doing it.
There's not a single word about the problem described here, and
I cannot see any connection with it (except that it is mailnews, too...).

So the fix for that bug did of course not fix this issue, which I also
see on 1.1b. So REOPENING.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
Reporter,

The reason why I duped it as dupe of bug 150716, is
because if you were to look at numerous dupes of
that bug you would see that it broke 'deleting several mesgs'.
And there was a comment about it breaking deleting mesgs:
http://bugzilla.mozilla.org/show_bug.cgi?id=150716#c11

So that was my reasoning when I duped it.

As for your problem,
I still cannot reproduce your problem using
trunk build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020826 

I sent myself 5 new mesgs to both my imap and pop account
I selected one of the new mesgs in my inbox. When I do shift-left mouse
and select multiple mesgs, it works. They stay selected and
none of the mesgs pops up.

What type of mail account are you running (imap, pop, etc..)
Does this occur if you use a new profile with same mail account?





(Reporter)

Comment 4

16 years ago
All those bugs deal with the fact that it simply hangs mailnews.
But this bug shows a very different symptom, and is persistent
after the fix for the other bug.
I'm running Pop. The problem only appears on the very first
instance of mailnews immediately  after start and reception
of the very first mails (so probably an initialization problem
of event handling). When several mails of the deletion group
have been read, the problem disappears.
I've not seen this on the Solaris Sparc builds yet.
(Reporter)

Comment 5

16 years ago
And it appears with a new profile, too.
(Reporter)

Comment 6

16 years ago
WFM Linux 1.1
This problem seems to have gone with the new release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
verified per reporter's comment.  thanks for reporting back.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.