Closed Bug 1561810 Opened 2 years ago Closed 2 years ago

Firefox Nightly - entering search terms containing "C#" will show up as "C" and "C++" will show up as "C+" - something to do with the url parsing?

Categories

(Firefox :: Address Bar, defect, P3)

69 Branch
defect
Points:
2

Tracking

()

RESOLVED DUPLICATE of bug 1560228
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: toastflaming, Unassigned)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [triagemonth-2019-06])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

type c# in the top search bar and press enter (on Google, if that matters)

Actual results:

google search for "c"

Expected results:

google search for "c#"

Component: Untriaged → Address Bar

Hi :toastflaming,

I tried the following Steps to reproduce the bug with 69.0a1 (2019-06-27) on my Windows 7 machine-

  1. Go to address bar and type c#
  2. Then press enter

Actual Result - Firefox searches for the term - 'c'.

Expected Result - Firefox should have searched for 'c#'.

As, I can reproduce this issue, I am confirming this bug.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [triagemonth-2019-06]

[Tracking Requested - why for this release]:

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b52d5b669b4323506372ae39958387aef3474230&tochange=b1be80f222f5ce65ce202726311fc5d3816f4344

Regressed by:
b1be80f222f5ce65ce202726311fc5d3816f4344 Marco Bonardo — Bug 1538050 - Split restriction characters only if they are at the beginning or end of the search string. r=adw

Marco Bonardo, Can you look into this?

Flags: needinfo?(mak77)
Regressed by: 1538050

Oh yes, the + at the end is interpreted as "limit search to tags", and # as "limit search to titles". I'm not sure there's a simple solution if we still want to allow just typing the restriction tokens naturally at the end of a string, like for example when typing questions to force a search behavior ("good name for a cat?").
Maybe we could avoid stripping the char if it's at the end, while still applying the restriction?

Points: --- → 2
Flags: needinfo?(mak77)
Priority: -- → P3

This is bug 1560228, right? Can we implement the suggestion in bug 1560228 comment 3?

good call, it's a dupe indeed.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1560228
You need to log in before you can comment on or make changes to this bug.