Closed Bug 1562058 Opened 5 months ago Closed 5 months ago

Intermittent browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: about:mozilla -

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1548111

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=253781188&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/eHwdNC3oRoy_ohpyOPvo3g/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/eHwdNC3oRoy_ohpyOPvo3g/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


9:42:36 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js
19:44:07 INFO - TEST-INFO | started process screenshot
19:44:07 INFO - TEST-INFO | screenshot: exit 0
19:44:07 INFO - <snipped 18 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
19:44:07 INFO - Buffered messages logged at 19:42:37
19:44:07 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch6 was found in autocomplete, was expected - true == true -
19:44:07 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Should have a tab switch result - 1 == 1 -

19:44:07 INFO - TEST-PASS | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 was found in autocomplete, was expected - true == true -
19:44:07 INFO - Leaving test bound step_5
19:44:07 INFO - Entering test bound step_6
19:44:07 INFO - Running step 6 - check swapBrowsersAndCloseOther preserves registered switch-to-tab result
19:44:07 INFO - Searching open pages.
19:44:07 INFO - Console message: [JavaScript Error: "Given tab is not restoring." {file: "resource:///modules/sessionstore/SessionStore.jsm" line: 5182}]
19:44:07 INFO - _resetLocalTabRestoringState@resource:///modules/sessionstore/SessionStore.jsm:5182:10
19:44:07 INFO - receiveMessage@resource:///modules/sessionstore/SessionStore.jsm:1035:30
19:44:07 INFO - MessageListener.receiveMessageonLoad/<@resource:///modules/sessionstore/SessionStore.jsm:1151:10
19:44:07 INFO - onLoad@resource:///modules/sessionstore/SessionStore.jsm:1149:14
19:44:07 INFO - onBeforeBrowserWindowShown@resource:///modules/sessionstore/SessionStore.jsm:1330:10
19:44:07 INFO - ssi_observe@resource:///modules/sessionstore/SessionStore.jsm:799:14
19:44:07 INFO - onLoad@chrome://browser/content/browser.js:1543:18
19:44:07 INFO - EventHandlerNonNull
@chrome://browser/content/browser.xhtml:112:39
19:44:07 INFO -
19:44:07 INFO - Buffered messages logged at 19:43:22
19:44:07 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
19:44:07 INFO - Buffered messages finished
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Test timed out -
19:44:07 INFO - GECKO(4144) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 110: uncaught exception: Object
19:44:07 INFO - GECKO(4144) | MEMORY STAT | vsize 797MB | vsizeMaxContiguous 685MB | residentFast 224MB | heapAllocated 87MB
19:44:07 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | took 90285ms
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: about:mozilla -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: data:text/html,<body><iframe src=""></iframe></body> -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - Not taking screenshot here: see the one that was previously logged
19:44:07 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | Found a tab after previous test timed out: https://example.com/browser/browser/components/urlbar/tests/browser/dummy_page.html#tabmatch16 -
19:44:07 INFO - checking window state
19:44:07 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 110}]

Regressed by: 1552410

Isn't this already filed as bug 1548111? (Which happened to be automatically resolved incomplete today)

Flags: needinfo?(apavel)
Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(apavel)
Resolution: --- → DUPLICATE
Duplicate of bug: 1548111
You need to log in before you can comment on or make changes to this bug.