Closed Bug 1562145 Opened 5 months ago Closed 4 months ago

unable to select a part of url by mouse-dragging

Categories

(Firefox :: Address Bar, defect, P1)

69 Branch
Desktop
Windows 10
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 + verified
firefox70 --- verified

People

(Reporter: alice0775, Assigned: harry)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

It is unable to select a part of url by mouse-dragging with clean new profile.
And it has been regressed by Bug 1554864.

Before landing Bug 1554864: mouse-down puts caret and mouse-dragging can select a part of url within dragging area. (Though clickSelectsAll is not working due to quantumbar bug)

After landing Bug 1554864: mouse-down selects whole url and mouse-dragging selects from beginning of url to mouse pointer.

Harry Twyford,
Your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(htwyford)

Steps to Reproduce:

  1. Open any page
  2. Make sure there are no focuses in an address bar
  3. Mouse down on url of the address bar. Do not mouse up
  4. Holding mouse down and move mouse

Actual Results:

  • step 3: Whole url is selected.
  • step 4: Text from the beginning of url to a mouse pointer is selected.

Expected Results:

  • step 3: Put caret at position of mousedown.
  • clickSelectsAll should be performed on click not mousedown.
  • step 4: Text from step 3 to current mouse position should be selected.
Priority: -- → P1
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Flags: needinfo?(htwyford)
Blocks: 1563539
Duplicate of this bug: 1563987
Points: --- → 3
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/04d628f57730
Fix mouse-dragging regression caused by patch to 1554864. r=dao

Backed out changeset 04d628f57730 (Bug 1562145) for bc failures in browser_bug1261299.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/2a3cb9e2b22ceff1bef713460294d4e3987a0e26

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&searchStr=browser%2Cchrome&fromchange=953a2bd4220bec9ea10512536aa06cf55288a972&tochange=2a3cb9e2b22ceff1bef713460294d4e3987a0e26&selectedJob=255448046

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=255447250&repo=autoland&lineNumber=1430

10:32:19 INFO - TEST-START | browser/base/content/test/general/browser_bug1261299.js
10:32:19 INFO - TEST-INFO | started process screencapture
10:32:19 INFO - TEST-INFO | screencapture: exit 0
10:32:19 INFO - Buffered messages logged at 10:32:19
10:32:19 INFO - Entering test bound test_content_and_chrome_selection
10:32:19 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
10:32:19 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<textarea id="textarea">Write something here</textarea>" line: 0}]
10:32:19 INFO - TEST-PASS | browser/base/content/test/general/browser_bug1261299.js | The macOS services got the selected content text -
10:32:19 INFO - Buffered messages finished
10:32:19 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1261299.js | The macOS services got the selected chrome text - Got Write something here, expected test.mozilla.org
10:32:19 INFO - Stack trace:
10:32:19 INFO - chrome://mochikit/content/browser-test.js:test_is:1591
10:32:19 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug1261299.js:test_content_and_chrome_selection:47
10:32:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1346
10:32:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1381
10:32:19 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1209
10:32:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
10:32:19 INFO - Leaving test bound test_content_and_chrome_selection
10:32:19 INFO - Entering test bound test_active_selection_switches_properly
10:32:19 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<textarea id="textarea">Write something here</textarea>" line: 0}]
10:32:20 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<textarea id="textarea">Nothing available</textarea>" line: 0}]

Flags: needinfo?(htwyford)

The newly posted patch fixes the failure on browser_bug1261299.js.

Flags: needinfo?(htwyford)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/759f04348891
Fix mouse-dragging regression caused by patch to 1554864. r=dao
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

If the target is FF 70, does that mean this regression will go live in 69?

Yes. I think this might be worth uplifting to beta in a few days if no more regressions come of it, seeing as all users are affected. Dao, thoughts on uplift?

Flags: needinfo?(dao+bmo)
No longer blocks: 1563539
Duplicate of this bug: 1563539

I verified that the issue was fixed on latest Nightly70.0a1 Windows10.
Build ID 20190710215049
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

(In reply to Harry Twyford [:harry] from comment #11)

Yes. I think this might be worth uplifting to beta in a few days if no more regressions come of it, seeing as all users are affected. Dao, thoughts on uplift?

Yes, this is already being tracked for 69. Please request uplift in the next few days (tomorrow or on Monday I'd say).

Status: RESOLVED → VERIFIED
Flags: needinfo?(dao+bmo)
Regressions: 1565273
Duplicate of this bug: 1564928

Yes, it would be good request approval before Monday's b5 go-to-build.

Flags: needinfo?(htwyford)

I agree it would be good to uplift, but this patch causes the additional regression bug 1565273. I’m of the mind that 1565273 is less-bad than this one, so it still makes sense to uplift this one, but I’m not sure of the general procedure when regression fixes cause additional issues. Could you offer some clarification on what we typically do there?

Flags: needinfo?(htwyford) → needinfo?(ryanvm)

I agree that this issue is more severe for users and bug 1565273 doesn't need to block uplift. I'll track the other bug too and we can take that fix on Beta after it's landed and baked.

Flags: needinfo?(ryanvm)

Thanks. I’m OoO atm and away from my laptop. I’ll be able to get back to it and post the uplift request before EOD on the West Coast.

Comment on attachment 9074777 [details]
Bug 1562145 - Fix mouse-dragging regression caused by patch to 1554864. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Annoying user interface behaviour in a very visible component (Urlbar) affecting all users.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Front-end code only; no user data is at risk. One regression has come of this patch (bug 156273) but that is a less severe user interface regression affecting only Windows users. No more regressions have been found in Nightly over the last three days.
  • String changes made/needed:
Attachment #9074777 - Flags: approval-mozilla-beta?

(In reply to Harry Twyford [:harry] from comment #20)

  • Why is the change risky/not risky? (and alternatives if risky): Front-end code only; no user data is at risk. One regression has come of this patch (bug 156273) but that is a less severe user interface regression affecting only Windows users. No more regressions have been found in Nightly over the last three days.

s/bug 156273/bug 1565273/ ... Absolutely agree that's less severe and we should uplift this while working on that bug.

QA Whiteboard: [qa-triaged]

Comment on attachment 9074777 [details]
Bug 1562145 - Fix mouse-dragging regression caused by patch to 1554864. r?dao

Fixes annoying text selection behavior in the URL bar. Approved for 69.0b5.

Attachment #9074777 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Iteration: --- → 70.1 - Jul 8 - 21

Verified as fixed on Firefox 69.0b5 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.14 and on Ubuntu 18.04 x64.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.