Closed Bug 1562394 Opened 2 years ago Closed 2 years ago

can't access favicon files on password protected site after authentication

Categories

(Firefox for Android Graveyard :: Favicon Handling, defect, P3)

Firefox 67
ARM
Android
defect

Tracking

(firefox67 wontfix, firefox68 wontfix, firefox69 fix-optional, firefox70 fix-optional)

RESOLVED DUPLICATE of bug 507641
Tracking Status
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fix-optional
firefox70 --- fix-optional

People

(Reporter: massimo.cassandro, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

After I have been authenticated to an apache passwd protected site, I tried to save a shortcut for the site and to add a bookmark in he main sites tab.

In both cases, Firefox is not be able to use the favicon files provided and use a generic icon.
Removing passwd protection, favicon file are correctly used.

This isseu does not occur using chrome for android

Actual results:

A generic icon is used for shortcut and bookmark

Expected results:

The provided favicon files should be used

Hi, can you provide the site you have used on which you encountered the problem?
Please provide the device and firmware.
On which Firefox build have you encountered the problem?

Flags: needinfo?(massimo.cassandro)

Hi Diana,
the site in question is under construction, anyway you can take a try at http://www.italianol2perbambini.it/
user test
pwd test

the device I used was a lenovo moto g5, android 8.1.0 plus (XT1685)
Firefox version is 67.0.3

Flags: needinfo?(massimo.cassandro)
Component: General → Awesomescreen
OS: Unspecified → Android
Hardware: Unspecified → ARM
Component: Awesomescreen → Favicon Handling

Hi, thank you for providing the site, it helped in reproducing the issue. I reproduce the mentioned issue with device Huawei Mate 20 lite(Android 8.1.0) and on LG K10(Android 7.0) on builds Firefox Release 67.0.3, Firefox Beta 68.0b14 and on Firefox Nightly 69.0a1(2019-07-02)

I will mark the ticket as NEW for further investigation.

Note: The issue is not reproduced on Chrome - the favicon is displayed

Status: UNCONFIRMED → NEW
Ever confirmed: true

Essentially a dupe of 507641. We use the Android OS networking to fetch the icons. It does not have any of the account info.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507641
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.