Closed Bug 1562465 Opened 9 months ago Closed 9 months ago

Intermittent [tier2] googleapiclient.errors.HttpError: <HttpError 403 when requesting https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/10447348290578812934/apks?alt=json&uploadType=media returned "APK

Categories

(Release Engineering :: Release Automation: Pushapk, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: jlorenzo)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=254135711&repo=mozilla-esr68
Full log: https://queue.taskcluster.net/v1/task/bFx-70-9RSuNqHZVrxNS4A/runs/0/artifacts/public/logs/live_backing.log


2019-06-30 10:06:44,080 - mozapkpublisher.common.googleplay - INFO - Uploading "/builds/scriptworker/work/cot/N0m4qlnSTCGAyVczaIGbwg/public/build/target.apk"
2019-06-30 10:06:44,082 - googleapiclient.discovery - WARNING - media_mime_type argument not specified: trying to auto-detect for /builds/scriptworker/work/cot/N0m4qlnSTCGAyVczaIGbwg/public/build/target.apk
2019-06-30 10:06:44,152 - googleapiclient.discovery - INFO - URL being requested: POST https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/10447348290578812934/apks?alt=json&uploadType=media
2019-06-30 10:06:54,129 - googleapiclient.http - WARNING - Encountered 403 Forbidden with reason "apkNotificationMessageKeyUpgradeVersionConflict"
Traceback (most recent call last):
File "/builds/scriptworker/bin/pushapkscript", line 11, in <module>
sys.exit(main())
File "/builds/scriptworker/lib/python3.6/site-packages/pushapkscript/script.py", line 137, in main
client.sync_main(async_main, config_path=config_path, default_config=get_default_config())
File "/builds/scriptworker/lib/python3.6/site-packages/scriptworker/client.py", line 164, in sync_main
loop.run_until_complete(_handle_asyncio_loop(async_main, context))
File "/tools/python3/lib/python3.6/asyncio/base_events.py", line 468, in run_until_complete
return future.result()
File "/builds/scriptworker/lib/python3.6/site-packages/scriptworker/client.py", line 204, in _handle_asyncio_loop
await async_main(context)
File "/builds/scriptworker/lib/python3.6/site-packages/pushapkscript/script.py", line 55, in async_main
strings_file)
File "/builds/scriptworker/lib/python3.6/site-packages/pushapkscript/googleplay.py", line 31, in publish_to_googleplay
skip_checks_fennec=bool(product_config.get('skip_checks_fennec')),
File "/builds/scriptworker/lib/python3.6/site-packages/mozapkpublisher/push_apk.py", line 111, in push_apk
rollout_percentage,
File "/builds/scriptworker/lib/python3.6/site-packages/mozapkpublisher/push_apk.py", line 135, in _upload_apks
edit_service.upload_apk(path)
File "/builds/scriptworker/lib/python3.6/site-packages/mozapkpublisher/common/googleplay.py", line 68, in _transaction_required
return method(*args, **kwargs)
File "/builds/scriptworker/lib/python3.6/site-packages/mozapkpublisher/common/googleplay.py", line 89, in upload_apk
media_body=apk_path
File "/builds/scriptworker/lib/python3.6/site-packages/googleapiclient/_helpers.py", line 130, in positional_wrapper
return wrapped(*args, **kwargs)
File "/builds/scriptworker/lib/python3.6/site-packages/googleapiclient/http.py", line 851, in execute
raise HttpError(resp, content, uri=self.uri)
googleapiclient.errors.HttpError: <HttpError 403 when requesting https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/10447348290578812934/apks?alt=json&uploadType=media returned "APK specifies a version code that has already been used.">
exit code: 1

Rerun is green.

Summary: Intermittent googleapiclient.errors.HttpError: <HttpError 403 when requesting https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/10447348290578812934/apks?alt=json&uploadType=media returned "APK → Intermittent [tier2] googleapiclient.errors.HttpError: <HttpError 403 when requesting https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/10447348290578812934/apks?alt=json&uploadType=media returned "APK

It looks like Google Play has a new error when an APK has already been uploaded. Original error was in bug 1554501.

Assignee: nobody → jlorenzo
Depends on: 1554501

The patch has been deployed. mozapkpublisher is now able to process this new error code. Closing this bug. Please let me know if you still see it.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Type: -- → defect
You need to log in before you can comment on or make changes to this bug.