Closed Bug 1562601 Opened 4 months ago Closed 3 months ago

Migrate the allow-muted pref

Categories

(Core :: Audio/Video, task, P2)

task
Points:
3

Tracking

()

VERIFIED FIXED
mozilla70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox69 --- verified
firefox70 --- verified

People

(Reporter: evilpie, Assigned: daleharvey)

References

Details

Attachments

(1 file)

Firefox has broken various autoplay prefs at least twice. The latest changes start ignoring media.autoplay.allow-muted, without migrating the pref. Can we migrate people with allow-muted: false to 5 = All-blocked?

Flags: needinfo?(dharvey)
Component: Site Identity and Permission Panels → Audio/Video
Product: Firefox → Core

Sure can take a look at adding that, is it a matter of adding a migration @ https://searchfox.org/mozilla-central/source/browser/components/BrowserGlue.jsm#3027 ? Never migrated a pref before

Flags: needinfo?(dharvey) → needinfo?(evilpies)
Assignee: nobody → dharvey

Sorry, I don't know how we migrate prefs. I would agree that what you are doing seems reasonable.

Flags: needinfo?(evilpies)
Priority: -- → P2
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/542a03a334cd
Migrate media.autoplay.allow-muted pref. r=Gijs
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Thanks for fixing this, but this also needs to be uplifted to 69 now.

Flags: needinfo?(dharvey)

Comment on attachment 9078137 [details]
Bug 1562601 - Migrate media.autoplay.allow-muted pref.

Beta/Release Uplift Approval Request

  • User impact if declined: Users who have set the aytoplay.allow-muted pref will see the autoplay behaviour reset when upgrading
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: * Install firefox 68
  • Set media.autoplay.allow-muted to false
  • Update to Nightly
  • Verify browser.autoplay.default = 5
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Pref migration which is unlikely to cause unexpected bugs
  • String changes made/needed:
Flags: needinfo?(dharvey)
Attachment #9078137 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9078137 [details]
Bug 1562601 - Migrate media.autoplay.allow-muted pref.

Avoid unexpected changes in autoplay behavior when upgrading. Approved for 69.0b14.

Attachment #9078137 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I tried to uplift this to beta, but got a conflict:
grafting 559501:542a03a334cd "Bug 1562601 - Migrate media.autoplay.allow-muted pref. r=Gijs"
merging browser/components/BrowserGlue.jsm
warning: conflicts while merging browser/components/BrowserGlue.jsm! (edit, then use 'hg resolve --mark')

Flags: needinfo?(dharvey)
QA Whiteboard: [qa-triaged]

I've tried to reproduce but I wasn't able to do that because can't update Firefox to a certain build only to the latest build.
I tested this issue using Firefox 69.0a1 (2019.07.01) I set media.autoplay.allow-muted to false then restart Firefox to update to the latest nightly (2019.08.19), verify that media.autoplay.default=5. Then using Firefox 68.0b3 set the pref to false, update Firefox to 69.0b14, verify the media.autoplay.default=5.
I can confirm this issue is fixed, I verified on nightly and on beta, Win 10 x64, Ubuntu 18.04 x64 and macOS 10.13.6.

Status: RESOLVED → VERIFIED
Iteration: --- → 70.3 - Aug 5 - 18
Points: --- → 3
You need to log in before you can comment on or make changes to this bug.