Closed Bug 156264 Opened 20 years ago Closed 11 years ago

Group similar tabs (or child-tabs) next to parent-tab

Categories

(SeaMonkey :: Tabbed Browser, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 558614

People

(Reporter: hramrach, Unassigned)

Details

There used to be a pref to open new tabs that are created by Accel-click on a
link  after the tab with the link (instead of opening always as the last tab).
That is tabs with content originating from one page were grouped together.

It surely had some problems but was useful anyway.
I'm missing it ;-(
As is suggested here, I would like to see tabs opened from an existing tab
appear to next to the tab from which the new tab was opened (hopefully that made
sense =).

This would resolve most of those problems with people complaining that closing a
tab doesn't take them to the "parent tab" while still retaining the simple and
predictable behavior that so many of the programmers seem to prefer.

I see why people do not want to implement any parent/child MDI stuff with the
tabs, but this would not require such a (possibly) confusing addition.

The behavior requested by this bug is consistent with NetCaptor's tabbed browsing.
tabbed browser issue
Assignee: ben → jaggernaut
Component: Preferences → Tabbed Browser
So what you want is a 'group similar tabs' option ?
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: No pref to open new tabs after parent page → [RFE] Group similar tabs (or child-tabs) next to parent-tab
Whiteboard: DUPEME
What is a similar tab? 

I wanted a tab opened inserted after the tab from which it was created by
opening a link. 
Not quite perfect but simple to implement IMHO.

I beleive this already worked but it might have been in Galeon.
QA Contact: sairuh → pmac
Summary: [RFE] Group similar tabs (or child-tabs) next to parent-tab → Group similar tabs (or child-tabs) next to parent-tab
I think an simple way to implement this would be to have child tabs opened to
the right of the current tab and have the tab focus go to the left (instead of
the current right) when closing a tab.
But then what about multiple children and grandchildren?
If you really wanted to be picky about it, it would require a lot of work, but a
simple quick-fix is described above.
multizilla (multizilla.mozdev.org) has preferences that will allow for the quick
fix I described in my previous comment. So there's no real need for mozilla to
worry about that. I'll leave my vote on this bug in hope that it will eventually
get fixed properly.
This could make browsing much more comfortable if it might be realized.

I also would like to give another suggestion about the tab. When I read a web
page, I often want to access a link by opening a new tab (possibily next to the
tab I'm reading) instead of opening it on the same one(when i finish reading the
new page and want to return to the previous page, I only need to close the
new-opened one and will not have to click BACK or type Alt+<-) or opening it in
a new window (which will make me to wait and seems also that it needs more
resources of the pc), what I hope it could be is, when I press the shift key and
click the link, a new tab of the link opens next to the current tab.

When I navigate under windows, I always use a really nice browser named MyIE2,
which is built based on IE core but enhanced much and I hope people who build
Mozilla would try it and they would find many interesting points in it and might
port them also to Mozilla.
(In reply to comment #7)

Forgot to give the link of myie2: http://www.myie2.com
Say you opened a tab from a link into the background next to the window you are
currently viewing.  Placing this child tab to the right of its parent throws off
the original chronology of the multiple tabs that are already opened, but then
it also organizes like subject matter, so there is a trade off here.  I don't
really know how important the initial chronology is to practical tab browsing,
anyway.

This may or may no be a good solution for those, who, like me, go through a set
of parent tabs everyday, and open links FROM THEM into the background all the
way to the right, then go to the next parent page.  This is possibly not the
most efficient habit, but it is what we current are stuck with.  

Maybe if this proposed option were available, I would rather surf in the
proposed way. I have gotten so used to the situations where I forget why I
initially opened a tab (often times on Slashdot discussions), because it opens
to the right of all the others, and so I can't check back to figure out which
parent I opened it from.

It seems logical to completely finish your business with one page ALONG WITH
going through all of its child tabs that you have opened, and THEN go to the
next parent tab that was already opened.  But this somewhat depends on how much
the child pages relate to the parent page.

Let me make one thing clear:

You have tabs A, B, and C already open.
You open child tabs A1 and A2 from A.
Now the tab bar should read A, A1, A2, B, C, NOT A, A2, A1, B, C.

In words, Firefox should know that A1 is already the first child of A, and so
open A2 to the right of A1.

You close A, and now are reading A1.  You open child tabs A1a and A1b from it
into the background.  The tab bar should now read A1, A1a, A1b, A2, B, C.

Now remember, all of this just relates to dealing with tabs that are opened into
the background.  For tabs that are opened into the foreground, there should be a
different set of rules that apply, because users that surf that way
fundamentally go about things differently.
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser
Fixed in Bug 558614
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a3
Resolution: FIXED → DUPLICATE
Duplicate of bug: 558614
Whiteboard: DUPEME
Target Milestone: seamonkey2.1a3 → ---
You need to log in before you can comment on or make changes to this bug.