Closed Bug 1562886 Opened 4 months ago Closed 4 months ago

Internal compiler error in skia Transform_inl.h

Categories

(Core :: Graphics, defect, P5)

68 Branch
Other
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr68 --- fixed
firefox69 --- fixed

People

(Reporter: msirringhaus, Assigned: lsalzman)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Compiling Firefox 68esr from source (mozilla-esr68) on s390x and i586 with GCC 7.4

Actual results:

Internal compiler error in gfx/skia/skia/third_party/skcms/src/Transform_inl.h in exec_ops().

There is a comment in that file stating that this happens for MIPS 64 and GCC.

I extended this check to s390x and the i*86-family. Now it builds.
Added the patch.

If this is acceptable, please consider uplifting this to mozilla-esr68.

Expected results:

Clean build.

Component: Untriaged → Graphics
Product: Firefox → Core
Flags: needinfo?(lsalzman)
OS: Unspecified → Linux
Priority: -- → P5
Hardware: Unspecified → Other
Flags: needinfo?(lsalzman)
Attachment #9075372 - Flags: review+
Keywords: checkin-needed

:lsalzman , I received "abort: bad hunk #1 @@ -559,7 +559,7 @@" when importing the patch

Flags: needinfo?(lsalzman)
Keywords: checkin-needed
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4f7ddb86b989
Avoid noinline on GCC with skcms to work around compiler error. r=me
Assignee: nobody → lsalzman
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(lsalzman)

Whoops, sorry that should be @@ -559,7 +559,8 @@.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Any possibility to get this uplifted into the 68esr branch?

Comment on attachment 9075372 [details] [diff] [review]
mozilla-gcc-internal-compiler-error.patch

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration:
  • User impact if declined: Not able to build on tier-3 Linux platforms due to GCC errors.
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just works around GCC build issues on tier-3. Doesn't affect other builds at all.
  • String or UUID changes made by this patch:
Attachment #9075372 - Flags: approval-mozilla-esr68?
Comment on attachment 9075372 [details] [diff] [review]
mozilla-gcc-internal-compiler-error.patch

NPOTB for supported platforms. Fixes a compilation failures on some Tier 3 platforms. Approved for 68.1esr.
Attachment #9075372 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
You need to log in before you can comment on or make changes to this bug.