Closed Bug 1562892 Opened 4 months ago Closed 4 months ago

Capture native fonts with WebRender

Categories

(Core :: Graphics: WebRender, enhancement, P4)

66 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: kvark, Assigned: kvark)

References

Details

Attachments

(1 file)

Currently, native fonts are all replaced with a dummy font when loading a capture. We don't attempt to save or load them correctly. This makes captures portable, but the result is always corrupted, since the glyph indices don't match.

It would be useful to save the native fonts, even if only to be replayed locally on the same machine. This way we'd get a matching scene rebuild with the way WR operates in Gecko.

Assignee: nobody → dmalyshau
Status: NEW → ASSIGNED
Priority: -- → P4

we save the native fonts by their full path now. On macOS, there is no
such thing as a full filesystem path for a CGFont (or at least we don't track it),
so loading a capture falls back to the old logic of using the dummy font.

Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd501b160508
WR capture native fonts as raw r=lsalzman
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1562286
You need to log in before you can comment on or make changes to this bug.