Closed Bug 1563024 Opened 5 months ago Closed 2 months ago

Add the ability to launch a search in private browsing mode from the context menu

Categories

(Firefox :: Search, task, P1)

task
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox71 --- verified

People

(Reporter: standard8, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

As part of the private browsing search engine changes, we want to add a new entry into the context mode (for non-private) to be able to launch a search in private browsing mode directly. This should also use the private browsing search engine.

Note: enable/disable display per the pref added in bug 1562922.

Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: P3 → P1
Attachment #9099836 - Attachment description: Bug 1563024 - Add a context menu item for the in-content popup to allow to perform a search in a new private window, using a private browsing mode default search engine. r?Standard8!,jaws! → Bug 1563024 - Add a context menu item for the in-content popup to allow to perform a search in a new private window, using a private browsing mode default search engine. r?jaws!,Standard8,mak
Attachment #9099837 - Attachment description: Bug 1563024 - Adapt unit tests to include coverage for the new Search in Private Window context menu option. r?Standard8 → Bug 1563024 - Adapt unit tests to include coverage for the new Search in Private Window context menu option. r?Standard8,mak
Iteration: --- → 71.3 - Sept 30 - Oct 13
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30c22dd7539e
Add a context menu item for the in-content popup to allow to perform a search in a new private window, using a private browsing mode default search engine. r=jaws,mak
https://hg.mozilla.org/integration/autoland/rev/cbc66b7170a6
Adapt unit tests to include coverage for the new Search in Private Window context menu option. r=mak
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+
QA Contact: pablo.muir

Hello! Reproduced the issue with Firefox 69.0a1 (20190702214807) in Windows 10x64.
The issue is verified fixed with Firefox 71.0b9(20191111170815) on Windows 10x64, macOS 10.14 and Ubuntu 18.04. A new context menu option is displayed "Search in a Private Window" while having browser.search.separatePrivateDefault.ui.enabled pref on true.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.