Closed Bug 1563093 Opened 1 year ago Closed 1 year ago

[Protections Panel] Properly style the anchor arrow color when navigating sub-views.

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: nhnt11, Assigned: nhnt11)

References

Details

(Whiteboard: [protection-report] [skyline])

Attachments

(2 files)

Per my investigation, this is not possible to do "properly" without modifying PanelMultiView.jsm. I decided to do this in its own bug so that I can get Gijs or someone else's input on the best way to deal with this.

Would be nice to get some context on what properly means here :)

Priority: -- → P1
Whiteboard: [privacy-panel][triage]
Whiteboard: [protection-report] [skyline]
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e07c0fe7189b
Set an attribute on PanelMultiView popups when the main view is showing, and use it to style the Protections Panel anchor arrow. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

I’ve reproduced this issue with Fx 70.0a1 (2019-07-30) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-10-14) and Fx 70.0b14 across platforms (Windows 10 x64, macOS 10.14, Ubuntu 18.04 x64).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.