Mozilla crashes on https url [@ HTMLAttribute::FindHTMLAttribute]

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
critical
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: Jiri Pejchal, Unassigned)

Tracking

({crash})

Trunk
Future
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla crashes everytime I visit https://b2b.dodejto.cz/B2B/Firma/Registrace
Build ID: 2002070808
Incident ID: TB8112482Y

Comment 1

16 years ago
after clicking the warning dialog about the certificate, I too crash with 2002070804
TB8114027Z
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> Layout (?)

HTMLAttribute::FindHTMLAttribute(nsIAtom * 0x01094778, HTMLAttribute * 
0xc0c0c0c0) line 221 + 6 bytes
nsHTMLAttributes::GetAttribute(const nsHTMLAttributes * const 0x04322758, 
nsIAtom * 0x01094778, const nsHTMLValue * * 0x0012c554) line 1303 + 16 bytes
nsGenericHTMLElement::GetAttr(const nsGenericHTMLElement * const 0x043226f0, int 
0, nsIAtom * 0x01094778, nsIAtom * & 0x00000000, nsAString & {...}) line 2123 + 
29 bytes
nsGenericHTMLElement::GetAttr(const nsGenericHTMLElement * const 0x043226f0, int 
0, nsIAtom * 0x01094778, nsAString & {...}) line 2104 + 48 bytes
FindNamedItems(const nsAString & {...}, nsIContent * 0x043226f0, 
IdAndNameMapEntry & {...}) line 3690
FindNamedItems(const nsAString & {...}, nsIContent * 0x04321448, 
IdAndNameMapEntry & {...}) line 3704 + 25 bytes
FindNamedItems(const nsAString & {...}, nsIContent * 0x04321280, 
IdAndNameMapEntry & {...}) line 3704 + 25 bytes
FindNamedItems(const nsAString & {...}, nsIContent * 0x04321148, 
IdAndNameMapEntry & {...}) line 3704 + 25 bytes
FindNamedItems(const nsAString & {...}, nsIContent * 0x04320e58, 
IdAndNameMapEntry & {...}) line 3704 + 25 bytes
.......
Assignee: Matti → attinasi
Severity: normal → critical
Component: Browser-General → Layout
Keywords: crash
QA Contact: asa → petersen
Created attachment 90525 [details]
Full stack trace

Comment 4

16 years ago
WFM w/ Mozilla 1.0, 2002052918@Linux and 20020606@Solaris8. Just accepted the
certificate and got the page.

Comment 5

16 years ago
confirming crash using build 2002070804 on Win2k. Does not crash on Linux (tried
build 20020708 and 20020705 trunk).

Updated

16 years ago
Assignee: attinasi → kmcclusk

Comment 6

16 years ago
Reassigning to Kevin Mc. (to reassign as he sees fit).

Updated

16 years ago
Summary: Mozilla crashes on https url → Mozilla crashes on https url [@ HTMLAttribute::FindHTMLAttribute]

Comment 7

16 years ago
I can't reproduce in the July 10 th build OS X (2002-07-10-08) and Windows Me
(2002-07-10-08).

Updated

16 years ago
QA Contact: petersen → moied
WFM: Using 2002/7/17 Moz 1.0 branch build on WinXP. Accepted the certificate and
it displayed the page.
I see the crash with win2k build 20020716..
I open the page in a new tab (in the background), accept the certificate dialog
and switch to the page.

kmcclusk@netscape.com: It is possible only on the trunk ?
->alexsavulov
Assignee: kmcclusk → alexsavulov

Comment 11

16 years ago
I can't reproduce using build 20020812on winXp, I got Site Error
An error was encountered while publishing this resource.
PoPy.OperationalError 
Priority: -- → P3

Comment 12

16 years ago
I cannot reproduce the crash in win2000+trunk20020809.
Bulk moving P1-P5 un-milestoned bugs to future. 
Target Milestone: --- → Future
->Content, although this sounds like a worksforme.
Assignee: alexsavulov → dom_bugs
Component: Layout → DOM HTML
QA Contact: moied → desale

Comment 15

15 years ago
all recent builds produce an "Error establishing an encrypted connection to
[address here] Error Code -8075". in 0.6.1 it still worked...
No crash Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040405
No indication of a "FindHTMLAttribute" string anywhere in LXR code.
No crashes reported on this bug since July 2002
--> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: desale → general
Crash Signature: [@ HTMLAttribute::FindHTMLAttribute]
You need to log in before you can comment on or make changes to this bug.