Java applets fail to initialize with SOCKS Proxy 5.

VERIFIED INVALID

Status

Core Graveyard
Java: OJI
VERIFIED INVALID
16 years ago
7 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: James.Melvin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Build ID: 7-8-2002, Windows 2000 trunk.

Summary: Java applets fail to initialize with SOCKS Proxy 5.

Steps to Reproduce:

1.  Enable a SOCKS Proxy 5 connection and load:
http://www.mozilla.org/quality/browser/front-end/testcases/oji/lifecycletest1.html

Expected Results:

Applet initializes.

Actual Results:

Applet fails to init.

Additional information from Bradley Baetz:

We need to talk to the java folks. ns4 only supported SOCKS v4, and 
so the old proxy API only discussed SOCKS v4. We need to get a new PAC 
code for SOCKS5 (bug 78176), and then get java to talk to it. SOCKS has no 
versioning compatability scheme, unfortunately.
Created attachment 90526 [details]
Dump of Java Console's output.
Rob, do you know anyone @ Sun that might be able to help out on this?

Comment 3

16 years ago
reassigning to jim for eval.
Assignee: new-network-bugs → James.Melvin
Blocks: 145287

Comment 4

16 years ago
Currently Java Plug-in (JRE) does not support socks 5. It has been proposed as 
an RFE for next release of JRE.
Can we/should we move this over to that component in Bugzilla, then?

Comment 6

16 years ago
changing component to oji.

resolving as invalid since this is a limitation of the jre, not mozilla.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Component: Networking → OJI
Resolution: --- → INVALID
thanks, verified.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.