Closed Bug 1563353 Opened 4 months ago Closed 3 months ago

Intermittent org.mozilla.geckoview.test.PromptDelegateTest.alertTest | status -2

Categories

(Testing :: Raptor, defect, P5)

Version 3
defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox68 unaffected, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: droeh)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=254619865&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/U_WLNrQ-REa3blr2bb11xw/runs/1/artifacts/public/logs/live_backing.log


[task 2019-07-03T16:58:38.366Z] 16:58:38 INFO - TEST-START | org.mozilla.geckoview.test.PromptDelegateTest.alertTest
[task 2019-07-03T17:00:41.340Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-07-03T17:00:41.340Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=110
[task 2019-07-03T17:00:41.340Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.PromptDelegateTest
[task 2019-07-03T17:00:41.340Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2019-07-03T17:00:41.341Z] 17:00:41 INFO - org.mozilla.geckoview.test | Error in alertTest(org.mozilla.geckoview.test.PromptDelegateTest):
[task 2019-07-03T17:00:41.341Z] 17:00:41 INFO - org.mozilla.geckoview.test | org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-07-03T17:00:41.341Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-07-03T17:00:41.341Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-07-03T17:00:41.342Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-07-03T17:00:41.342Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-07-03T17:00:41.342Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-07-03T17:00:41.342Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-07-03T17:00:41.342Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-07-03T17:00:41.343Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1241)
[task 2019-07-03T17:00:41.343Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-07-03T17:00:41.343Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-07-03T17:00:41.344Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-07-03T17:00:41.344Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-07-03T17:00:41.346Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-07-03T17:00:41.346Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-07-03T17:00:41.347Z] 17:00:41 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-07-03T17:00:41.348Z] 17:00:41 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-07-03T17:00:41.348Z] 17:00:41 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-07-03T17:00:41.349Z] 17:00:41 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-07-03T17:00:41.349Z] 17:00:41 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-07-03T17:00:41.349Z] 17:00:41 INFO - org.mozilla.geckoview.test |
[task 2019-07-03T17:00:41.349Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=160
[task 2019-07-03T17:00:41.350Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-07-03T17:00:41.350Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-07-03T17:00:41.350Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-07-03T17:00:41.350Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-07-03T17:00:41.351Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-07-03T17:00:41.351Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-07-03T17:00:41.351Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-07-03T17:00:41.352Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-07-03T17:00:41.353Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1241)
[task 2019-07-03T17:00:41.353Z] 17:00:41 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-07-03T17:00:41.354Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-07-03T17:00:41.355Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-07-03T17:00:41.355Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-07-03T17:00:41.356Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-07-03T17:00:41.356Z] 17:00:41 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-07-03T17:00:41.357Z] 17:00:41 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-07-03T17:00:41.358Z] 17:00:41 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-07-03T17:00:41.358Z] 17:00:41 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-07-03T17:00:41.359Z] 17:00:41 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-07-03T17:00:41.359Z] 17:00:41 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-07-03T17:00:41.360Z] 17:00:41 INFO - org.mozilla.geckoview.test |
[task 2019-07-03T17:00:41.360Z] 17:00:41 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=alertTest

This looks like a regression from bug 1499396, Dylan can you take a look?

Flags: needinfo?(droeh)
Regressed by: 1499396

Joel, both this bug and bug 1563376 are regressed by 1499396, these are tier1 failures, do we backout?

Flags: needinfo?(jmaher)

:apavel, yes- please backout the patch in bug 1499396

Flags: needinfo?(jmaher)

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #3)

:apavel, yes- please backout the patch in bug 1499396

I believe this is the same bug we see on dozens of other GV JUnit tests -- it should be fixed by bug 1501574. I would prefer not backing out this patch, as there's nothing we can do with the patch itself to solve this issue.

Flags: needinfo?(droeh)

(In reply to Dylan Roeh (:droeh) (he/him) from comment #4)

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #3)

:apavel, yes- please backout the patch in bug 1499396

I believe this is the same bug we see on dozens of other GV JUnit tests -- it should be fixed by bug 1501574. I would prefer not backing out this patch, as there's nothing we can do with the patch itself to solve this issue.

Followup: Talked to snorp about this, I'll put up a patch to disable the two specific tests that are failing rather than backing out the entire thing.

sounds good, thanks :droeh. We have a storm of failures lately and are taking a stronger approach to get many of our tests under control- this just sort of landed at the wrong time to get caught up in the mess. I do look forward to junit running on the new emulators :)

Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2102472ba072
Disable two PromptDelegate tests for intermittent failures. r=snorp

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

(In reply to Andreea Pavel [:apavel] from comment #10)

Hi Dylan, i believe this is from here too https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=255151766&resultStatus=pending%2Crunning%2Csuccess%2Ctestfailed%2Cbusted%2Cexception&classifiedState=unclassified&searchStr=android%2C4.3%2Capi16%2B%2Cpgo%2Ctest-android-em-4.3-arm7-api-16%2Fpgo-geckoview-junit-e10s-1%2C%28gv-junit1%29

I've hit retrigger and are waiting for results.

As I understand it, the waitForInitialLoad timeout can happen on any gv-junit test. Is it happening frequently enough on textTest to justify disabling it?

Flags: needinfo?(droeh)

No, 11 failures in the last ~4 days according to bug 1563969.

You need to log in before you can comment on or make changes to this bug.