Closed Bug 1563393 Opened 7 months ago Closed 6 months ago

Ctrl+Tab thumbnail scaling doesn't follow window scaling

Categories

(Firefox :: Tabbed Browser, defect, P3)

Desktop
Unspecified
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox70 --- verified

People

(Reporter: agashlin, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image Going from 250% to 300%

STR:

  1. Set the OS scaling to 250% (in Windows 10 this is "Change the size of text, apps, and other items")
  2. Start Firefox
  3. Change the scaling to 300%
  4. Press and hold Ctrl+Tab

The tab thumbnails are the wrong size, overlapping.

This generally happens for me when I move the window between two monitors with different scaling. Sometimes the whole popup appears at the top of the screen instead of centered. Restarting Firefox corrects the issue.

I suspect that this is a Win32 widgets issue, but it might be more general.

The priority flag is not set for this bug.
:aswan, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(aswan)
Component: XUL Widgets → Tabbed Browser
Flags: needinfo?(aswan)
Product: Toolkit → Firefox
Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 70.1 - Jul 8 - 21
Points: --- → 2
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/844bddb7d0f4
Stop caching the ctrl+tab thumbnail canvas size. r=aswan
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

I didn't managed to reproduce the issue following the STR from the first comment, I tried to reproduce the issue on Win10 on both x32 and x64 builds. If you could please verify that the issue is fixed using this link: https://archive.mozilla.org/pub/devedition/candidates/70.0b11-candidates/build1/.

Flags: needinfo?(agashlin)

Sorry, the STR was incomplete. A better version is:

  1. Set scaling to 250%
  2. Start Firefox
  3. Open many tabs, enough that they won't all fit in the ctrl-tab thumbnail view (this has to be done before changing the scaling, I think)
  4. Ctrl-tab, the first few thumbnails will appear properly spaced
  5. Change scaling to 300%
  6. Ctrl-tab, the thumbnails overlap

Using this I was able to reproduce on 69.0.2, and was not able to reproduce on the dev edition build linked in comment 5. Thanks!

Status: RESOLVED → VERIFIED
Flags: needinfo?(agashlin)

Thank you for the help. I have verifyed that the issue isn't reproducing on the latest beta to.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.