Closed Bug 1563541 Opened 5 months ago Closed 4 months ago

Intermittent gfx/layers/apz/test/mochitest/test_bug1253683.html | expected at least one nonempty paint

Categories

(Core :: Panning and Zooming, defect, P5)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=254741259&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/Rzg1Ww_nQICkfbdA_ZENOw/runs/0/artifacts/public/logs/live_backing.log


12:39:08 INFO - TEST-START | gfx/layers/apz/test/mochitest/test_bug1253683.html
12:39:08 INFO - GECKO(8172) | Parent process: flushed APZ repaints, waiting for callback...
12:39:08 INFO - GECKO(8172) | Flushed APZ repaints, waiting for callback...
12:39:08 INFO - TEST-INFO | started process screenshot
12:39:08 INFO - TEST-INFO | screenshot: exit 0
12:39:08 INFO - Buffered messages logged at 12:39:08
12:39:08 INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_bug1253683.html | Initial scrollY should be 0
12:39:08 INFO - Buffered messages finished
12:39:08 INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_bug1253683.html | expected at least one nonempty paint
12:39:08 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
12:39:08 INFO - isLayerized@gfx/layers/apz/test/mochitest/apz_test_utils.js:156:3
12:39:08 INFO - test@gfx/layers/apz/test/mochitest/test_bug1253683.html:30:7
12:39:08 INFO - driveTest@gfx/layers/apz/test/mochitest/apz_test_utils.js:504:36
12:39:08 INFO - runContinuation/</<@gfx/layers/apz/test/mochitest/apz_test_utils.js:511:9
12:39:08 INFO - runContinuation/<@gfx/layers/apz/test/mochitest/apz_test_utils.js:497:12
12:39:08 INFO - promise callback*@gfx/layers/apz/test/mochitest/test_bug1253683.html:52:4
12:39:08 INFO - Not taking screenshot here: see the one that was previously logged
12:39:08 INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_bug1253683.html | APZ test continuation failed with exception: TypeError: nonEmptyBucket is null
12:39:08 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
12:39:08 INFO - runContinuation/</<@gfx/layers/apz/test/mochitest/apz_test_utils.js:513:20
12:39:08 INFO - runContinuation/<@gfx/layers/apz/test/mochitest/apz_test_utils.js:497:12
12:39:08 INFO - promise callback*@gfx/layers/apz/test/mochitest/test_bug1253683.html:52:4
12:44:36 INFO - Not taking screenshot here: see the one that was previously logged
12:44:36 INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_bug1253683.html | Test timed out.
12:44:36 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
12:44:36 INFO - reportError@SimpleTest/TestRunner.js:121:22
12:44:36 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Type: -- → defect

This seems to have started fairly recently. I'm going to do retriggers to see if I can find what caused it.

Retriggers are not producing much to go on. However I was able to reproduce this locally on macOS with some debug logging. It seems like the content paint happens early during page load, before the APZ test logging pref is flipped. Then we do the waitUntilApzStable which is mostly a no-op since everything is already stable, and then we start the test. So between the pref getting flipped and reading the APZ test data, there's no actual paints. If I add a forceLayerTreeToCompositor call it seems to fix it for me locally (hard to confirm, but I haven't hit the problem yet with that change).

Assignee: nobody → kats
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3accce0da9b4
Force a paint before reading the APZ test data. r=botond
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.