Closed Bug 1563565 Opened 1 year ago Closed 1 year ago

Stub installer gets stuck at ~60% on ARM

Categories

(Firefox :: Installer, defect, P1)

ARM64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- verified
firefox70 --- verified

People

(Reporter: gyula.palko, Assigned: mhowell)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Environment:]
69.0a1 Nightly Win10/aarch64

[Steps:]
Download and run the Installer from https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/

[Actual Result:]
The installer gets stuck at ~60%, Nightly is not installed

[Expected Result:]
FF Nightly should be successfully installed

[Note]
Tested on Lenovo Yoga

Easily reproducible for me; I'll investigate.

This could be a regression from bug 1553537, but I'm not sure yet.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Priority: -- → P1

Confirmed this is definitely bug 1553537. No idea yet why that change would cause this, and only on ARM64.

[Tracking Requested - why for this release]:
This bug makes the stub installer effectively useless on ARM64 Windows.

Keywords: regression
Regressed by: 1553537

I found the problem. As a basic sanity check, the stub installer compares the size of the full installer that it downloads against an expected minimum and maximum. If that fails we retry the download. The ARM64 installer has exceeded the maximum (which is 70 MB) primarily because of bug 1529194 and its bundling of most of an x86 build inside of the ARM64 build, so we're just retrying forever.

I do not understand why bug 1553537 caused this check to start triggering when it was not before. My guess is that some timing condition was causing the file size to not be reported properly, since I can occasionally get the install to succeed even with this bug in place. Given the above, I think the proper fix is really just to raise the maximum download size value. With the current state of the code everything seems to be working as expected, so I think that's the only necessary change.

The installer for aarch64 Windows has exceeded the current limit. This new one
(150 MB) should allow enough breathing room while still being reasonable.

Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a652f09ed1cf
Raise the stub installer maximum download size limit. r=agashlin

Comment on attachment 9078543 [details]
Bug 1563565 - Raise the stub installer maximum download size limit. r=agashlin

Beta/Release Uplift Approval Request

  • User impact if declined: The stub installer is effectively useless on ARM64 Windows machines.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch simply raises the installer size limit and doesn't include any other changes.
  • String changes made/needed:
Attachment #9078543 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Comment on attachment 9078543 [details]
Bug 1563565 - Raise the stub installer maximum download size limit. r=agashlin

Stub installer fix needed for ARM64 builds. Approved for 69.0b6.

Attachment #9078543 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified - fixed on latest Nightly 70.0a1 (2019-07-18) on Lenovo Yoga Win10/aarch64.

Verified - fixed on latest Beta 69.0b6 on Lenovo Yoga Win10/aarch64.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.