Text corrupt by scrolling

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: cowwoc2020, Assigned: samir_bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.1a+) Gecko/20020703
BuildID:    2002070308



Reproducible: Always
Steps to Reproduce:
1. Visit URL
2. Scroll up/down using arrow keys
3. Notice text is cut off and corrupt (see screenshot)
(Reporter)

Comment 1

17 years ago
Created attachment 90586 [details]
Notice the text near the bottom of the text is cut-off and corrupt

Comment 2

17 years ago
This problem started happening after the patch for bug 97861 got 
checked in - nsTransform2DOS2.cpp
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Created attachment 95381 [details]
Monospace Letter Gothic 18 with rows of pixels missing.

I have also been seeing this corruption for the last release few releases.
I am on 1.1b currently.
I have tried different Mozilla fonts, sizes, display resolutions, S3 video
drivers, and currently SDD709se drivers, so it is good to see it's Mozilla
and I'm not going mad.

Comment 4

17 years ago
Created attachment 95382 [details]
GIF images with corruption - missing line of pixels.

Comment 5

17 years ago
Created attachment 95383 [details]
GIF images are now correct.

Comment 6

17 years ago
I added two extra attachments to show the effect on graphical images.
Clicking on one of the GIF images will immediately correct it, and it will
appear to grow downwards by one line of pixels.  The other GIF images will not
change until they are also clicked on.  These GIF images sit over hypertext links.

With the corruption of text - highlighting of the text will cause it to be
redrawn correctly, but only the highlighted area.

With both graphics and text, if another program's window is placed over the
corruption, and then moved away, the corruption is seen to be corrected.  Any
graphics or text not covered this way will remain corrupted.
Created attachment 95903 [details] [diff] [review]
Stop building nsTransform2DOS2.cpp

Go back to building the regular nsTransform2D.cpp on OS/2, since the OS/2
specific version is causing more severe problems than it solves.
Comment on attachment 95903 [details] [diff] [review]
Stop building nsTransform2DOS2.cpp

r=cls
Attachment #95903 - Flags: review+

Comment 9

17 years ago
Seems to be similar to bug 119182
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
verified - I no longer see the corrupt text from scrolling
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.