If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP][IME-X]Editor Plain Text-Needs to commit twice to display Japanese chars

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Hidetoshi Tajima)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When you type Japanese characters in the Editor Plain Text Window, you need to
hit the Enter twice to display Japanese characters.

Steps of reproduce
1. Open Plain text Editor
2. Turn on IME by Shift+Space
3. Type Japanese characters like "kannji" in hiragana mode
4. Hit space key to change to Kannji
5. Hit Enter to commit

At this time, Japanese characters is not displayed.
Then, hit Enter again.  Now Japanese characters is displayed.

When you type Japanese characters at the beginnig of the first line, this works
fine. However, if you contine to type Japanese characters, you will see this
problem.

Using Kinput2.  Tested 10-01-M10 Linux build.  This does not happen in HTML
editor.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

18 years ago
Accepted, and I'm trying to reproduced the problem, without any luck yet.
(Assignee)

Comment 2

18 years ago
Trying to reproduce the problem, without a luck, so far. Any specific engine is
to
be used to reproduce? Wnn6, Canna, etc?
(Reporter)

Comment 3

18 years ago
We are using Wnn4.2-9JRPM60.i386.rpm, kinput2-wnn4-v3-2JRPM60.i386.rpm, and
locale-ja-2.1.1.1-2.noarch.rpm.
Tajima-san, I will test again this after I change my linux environment from
your suggestion.

Updated

18 years ago
Blocks: 16127

Updated

18 years ago
Summary: [PP]Editor Plain Text-Needs to commit twice to display Japanese chars → [PP][IME-X]Editor Plain Text-Needs to commit twice to display Japanese chars
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

18 years ago
This does not apply since Plain Text Editer window is not there.

Comment 5

18 years ago
The plaintext editor now lives in the editor debug menu.
(Assignee)

Updated

18 years ago
Target Milestone: M12
(Assignee)

Comment 6

18 years ago
Teruko-san, have you tested this again with the plantext editor? Will you please
try
this again with latest build?
(Reporter)

Comment 7

18 years ago
I tested this in 11-15-12 Linux build.  I found the Plain Text editor from Debug
menu.  I could not reproduce this anymore.
You need to log in before you can comment on or make changes to this bug.