Closed Bug 1564267 Opened 5 years ago Closed 5 years ago

Formatted console logs with larger font-height are cut off by fixed line-height

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 fixed, firefox68 wontfix, firefox69 fixed, firefox70 fixed)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: Harald, Assigned: fvsch)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [good first verify] [bugday-20190807] )

Attachments

(2 files)

Attached image image.png

What were you doing?

  1. Open Console
  2. Execute console.log("%cIs this visible enough?", "color: cyan; font-size: 6rem;")

What happened?

Text is cut off because of fixed line-height.

What should have happened?

Text shows in correct font-size and height.

Anything else we should know?

Works in 67.

Regressed by me in https://hg.mozilla.org/mozilla-central/rev/23ab80e6ec5318991ef646bc74515bd4347d0da1#l1.14

Not sure why I moved away from the calc(14 / 11) value, it's usually not a good idea to use fixed values for line-height as shown by this bug.

Regressed by: 1519904

Affected versions:

  • Firefox 69 (beta)
  • Firefox 68 (release, ESR)

Haven't confirmed in 68, but the regressing patch landed on 2019-05-14, and Firefox 68 merge date was 2019-05-20.

Pushed by florens@fvsch.com:
https://hg.mozilla.org/integration/autoland/rev/9f5318689ae7
Fix console line-height for large text; r=nchevobbe
Assignee: nobody → florens
Status: NEW → ASSIGNED
Keywords: leave-open
Keywords: leave-open

Comment on attachment 9076724 [details]
Bug 1564267 - Fix console line-height for large text; r=nchevobbe

Beta/Release Uplift Approval Request

  • User impact if declined: Console messages logged by some JS frameworks or libraries may be unreadable, hurting web developer experience.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only patch changing a single value.
  • String changes made/needed:
Attachment #9076724 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Comment on attachment 9076724 [details]
Bug 1564267 - Fix console line-height for large text; r=nchevobbe

Yikes. Approved for 69.0b5 and 68.1esr.

Attachment #9076724 - Flags: approval-mozilla-esr68+
Attachment #9076724 - Flags: approval-mozilla-beta?
Attachment #9076724 - Flags: approval-mozilla-beta+
Whiteboard: [good first verify]

The issue is no longer reproducible on Firefox 69.0b5 (64-bit), Firefox 70.0a1 (2019-07-18) (64-bit).
Tests were performed under Windows 10 Pro 10.0.17134.

The issue is no longer reproducible on Firefox 69.0b5 (64-bit), Firefox 70.0a1 (2019-07-18) (64-bit).
Tests were performed under Kubuntu 18.04.2 LTS bionic (64-bit).
I apologize for the two posts, but wasn't aware that I can't change comments here.

I have reproduced this bug with Nightly 70.0a1 (2019-07-08) on Windows 7, 64 Bit. The fix of the bug is verified with latest Beta 69.0b9 and latest Nightly.

Build ID 20190730004747
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Build ID 20190812215403
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Status: RESOLVED → VERIFIED
Whiteboard: [good first verify] → [good first verify] [bugday-20190807]
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: