Closed Bug 1564299 Opened 5 months ago Closed 5 months ago

Fission a11y: Reorder event not fired on iframe accessible after OOP iframe is loaded

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Fission Milestone M4
Tracking Status
firefox70 --- fixed

People

(Reporter: Jamie, Assigned: Jamie)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When opening a document with an OOP iframe, NVDA's virtual buffer sometimes doesn't include the content of the iframe once loaded. However, pressing NVDA+f5 to force refresh the buffer then shows the iframe's content as expected. I'm fairly sure this is because the iframe isn't firing a reorder event when the OOP DocAccessibleParent is added.

For same-process iframes, this gets handled by DocAccessible::DoInitialUpdate, since the iframe accessible is in the same process and is the parent of the document. This can't work for OOP iframes.

I think this event is going to need to be fired directly by the parent process, probably in DocAccessibleParent::AddChildDoc.

Fission Milestone: --- → M4

For same-process iframe documents, this reorder event is fired by the content process.
This isn't possible when the document is in a different process to its embedder.
In this case, we need to fire it from the parent process when the embedded document accessible is added.

Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf25c3b58362
Fire a reorder event on the outer doc accessible when an OOP document gets added. r=yzen
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1593892
You need to log in before you can comment on or make changes to this bug.