Closed Bug 1564580 Opened 1 year ago Closed 1 year ago

Firefox starts with a new profile if started with lowercase path

Categories

(Toolkit :: Startup and Profile System, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1555319
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: moz, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

  1. Start Firefox (version 67.0.4 on Windows 10 Enterprise 1703)
  2. open a cmd
  3. execute "c:\program files\mozilla firefox\firefox.exe" [url]

Actual results:

The third command opens a separate Firefox window with a new/different profile. As a result, all settings are unavailable including saved passwords. This gives the impression that firefox lost all configuration.

Expected results:

Open [url] in the existing Firefox instance. This also works fine if executing the upper-cased path "C:\Program Files\Mozilla Firefox\firefox.exe" [url] instead.

See also: https://developercommunity.visualstudio.com/content/problem/598424/create-a-pull-request-opens-in-a-new-profile-of-fi.html

Component: Untriaged → Startup and Profile System
Keywords: regression
Product: Firefox → Toolkit
Regressed by: 1474285
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1555319
You need to log in before you can comment on or make changes to this bug.