Closed Bug 1564846 Opened 2 years ago Closed 1 year ago

Geckoview test app generates spurious EGL errors due to GC'd SurfaceTextures

Categories

(GeckoView :: General, defect, P2)

Unspecified
All

Tracking

(firefox68 wontfix, firefox69 wontfix, firefox70 wontfix, firefox71 wontfix, firefox72 wontfix, firefox73 fixed)

RESOLVED FIXED
mozilla73
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- fixed

People

(Reporter: kats, Assigned: snorp)

References

(Regressed 1 open bug)

Details

Attachments

(1 file)

Spinoff from https://bugzilla.mozilla.org/show_bug.cgi?id=1516298#c28

The Geckoview test app doesn't hold on to the SurfaceTexture instances it creates, so creating a bunch that are active and then triggering a GC will result in Surfaces that are not backed by anything, and causes random test failures.

:snorp wrote a patch that seems to address it, filing this bug to get that landed.

Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b8f19d6b8762
Do better at managing secondary windows in TestRunnerActivity r=kats
Flags: needinfo?(snorp)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressed by: 1565072
No longer regressed by: 1565072
Regressions: 1565072

Might be related to what I observed about Surface when investigating an older css-backgrounds wpt intermittent: https://bugzilla.mozilla.org/show_bug.cgi?id=1554777#c12

See Also: → 1554777
No longer blocks: 1476893

69=wontfix because James says we don't need to uplift this fix to 69 Beta. We might need to back it out from 70 Nightly for the test issues.

Flags: needinfo?(snorp)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla70 → ---
Priority: -- → P1

I'm editing a bunch of GeckoView bugs. If you'd like to filter all this bugmail, search and destroy emails containing this UUID:

e88a5094-0fc0-4b7c-b7c5-aef00a11dbc9

Priority: P1 → P2
Rank: 30
Attachment #9077107 - Attachment is obsolete: true

:snorp, I am pretty sure your patch fixes bug 1476893. And the failure tests in bug 1565072 have been disabled for a while. I think we can land your patch now.

Here is a try with the patch.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f115dd5878359a8b6f7c1fcdbd25f24e28def0dd

Flags: needinfo?(snorp)
Attachment #9077107 - Attachment is obsolete: false
Attachment #9077107 - Attachment description: Bug 1564846 - Do better at managing secondary windows in TestRunnerActivity → Bug 1564846 - Do better at managing secondary windows in TestRunnerActivity r?
Pushed by hikezoe.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2bdcf118f101
Do better at managing secondary windows in TestRunnerActivity r=kats

lgtm if it works :)

Flags: needinfo?(snorp)
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.