Closed Bug 1564873 Opened 1 year ago Closed 1 year ago

Use MaybeUninit instead of mem::uninitialized in WebRender

Categories

(Core :: Graphics: WebRender, enhancement)

66 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: SimonSapin, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Part of bug 1563623.

MozReview-Commit-ID: 67kmn5v43eW

Depends on: rustup
Depends on: 1565193
No longer depends on: rustup

There are no reviewers specified on these patches. Is that intentional?

Flags: needinfo?(simon.sapin)

Added gfx as a reviewer. I think it represents anyone in that group?

Flags: needinfo?(simon.sapin)

(In reply to Simon Sapin (:SimonSapin) from comment #5)

Added gfx as a reviewer. I think it represents anyone in that group?

I chnaged the reviewer to Gankro. The gfx reviewer is left over from the early WR workflows but isn't really used now. I'll remove that phabricator account if I can.

Alexis, do you mind taking a look at this again? 1.39 turns this into a warning which broke our CI. As a workaround we'll probably switch to 1.38 but we should probably do something sooner rather than later.

Flags: needinfo?(a.beingessner)

Do you want me to do it or is Simon planning a rebase?

Flags: needinfo?(a.beingessner)

I have no preference. I'll let you two fight it out.

Flags: needinfo?(simon.sapin)

Alexis, could you take over? I started this hoping apply similar patterns of changes in all of Gecko, but that Vec of GPU data probably deserves more attention than that and I don’t really understand what makes it sound or how it could be made sound.

Flags: needinfo?(simon.sapin) → needinfo?(a.beingessner)

Use Vec::reserve + as_ptr, then raw pointers.

Alternative is to require T: Default, and then push T::default() or something.

Depends on D53359

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/582c1acfb348
Stop using mem::uninitialized to pass memory to the GPU. r=Gankro
Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82e4062e839a
Fix straight-forward uses of mem::uninitialized in webrender. r=nical
Assignee: simon.sapin → emilio
Keywords: leave-open
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Duplicate of this bug: 1596311
Flags: needinfo?(a.beingessner)
You need to log in before you can comment on or make changes to this bug.