Closed Bug 1564881 Opened 1 year ago Closed 1 year ago

Firefox stuck at new tab after v68 update because of Symantec block exe downloads

Categories

(Firefox :: Untriaged, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: irock4u79, Unassigned, NeedInfo)

Details

Attachments

(1 file)

504.20 KB, video/mp4
Details
Attached video aaa.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

Steps to reproduce:

Updated Firefox to version 68

Actual results:

Firefox is stuck at new tab. No matter what I search for, no matter what website I enter. No matter what website I try to enter. This happened after Firefox updated from v67 to v68. I have tried downgrading to v67 and it works fine. So the problem is isolated to v68. I have completely unblocked my Firewall to allow all internet traffic. I have no extensions, add ons, themes, etc. I have tried both safe mode and refreshed the Firefox. None of them have helped. Only possibility I can think of is that there is some GPO that's causing but I am not sure if we have any in place that might affect something like this. A machine not in the Windows domain works fine.

Expected results:

Firefox should be able to go to any website and open new tabs as required.

Also this is not limited to one machine. Its all of the machines under that domain.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

Stupid Symantec blocking Firefox for some reason.

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Firefox stuck at new tab after v68 update → Firefox stuck at new tab after v68 update because of Symantec block exe downloads

I would like to get a resolution to this if possible. The problem is this. After updating to v68, Firefox is stuck on a new tab and not doing anything. Its not possible to open any website. Its not possible to open a new tab (Have tried refresh,uninstall,etc). Upon investigating I found that we have a policy in Symantec Endpoint Protection that disables all exe downloads from all browsers. If I turn that policy off, Firefox works fine. But we can't do that for security reasons. So my question is what has changed in v68 (v67 works fine) that is trying to download an exe under the hood? We have no plugins, extensions, themes, addons installed whatsoever.

Hi,

Sorry for the delay. I've been looking around, would you like to try what's suggested here? https://bugzilla.mozilla.org/show_bug.cgi?id=1513645. Go to about:config, and modify the setting security.pki.distrust_ca_policy. The Firefox preference "security.pki.distrust_ca_policy" may be set to '2' to enable distrust (regardless of issuance date) and '0' to override these changes. Mozilla plans to remove this preference in Firefox 65.

Let me know if it helps. Best regards, Flor.

Flags: needinfo?(irock4u79)

Hi,

I'm marking this as Resolved-Incomplete due to lack of response. If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.

Best regards, Flor.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.