javascript assertation: me == CurrentThreadId()

VERIFIED DUPLICATE of bug 14049

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED DUPLICATE of bug 14049
19 years ago
17 years ago

People

(Reporter: tor, Assigned: rogerl (gone))

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Visit the indicated URL and click on the "see plans" button to the
right of the text field.  apprunner will crash with an assertation.
Seen in a 10/5 evening pull on solaris/native.

Document http://www.point.com/plans loaded successfully
Document: Done (7.952 secs)
Skipping libjsurl.so, already read
Assertion failure: me == CurrentThreadId(), at
/cs/src/mozilla/mozilla/js/src/jslock.c:258
t@5 (l@1) signal ABRT (Abort) in __sigprocmask at 0xfed49968
0xfed49968: __sigprocmask+0x0008:       retl
Current function is JS_Assert
  146       abort();
(dbx) where
current thread: t@5
  [1] __sigprocmask(0x0, 0xfd9231b0, 0x0, 0xffffffff, 0xffffffff, 0x0), at
0xfed49968
  [2] _resetsig(0xfed5c524, 0x0, 0xfd923dc8, 0x0, 0x0, 0xfd923e44), at
0xfed3f1e8
  [3] _sigon(0xfed61040, 0xfed60fa0, 0xfd923e3c, 0xfd923284, 0x6, 0x5), at
0xfed3e934
  [4] _thrp_kill(0x0, 0x5, 0x6, 0xfed5c524, 0xfd923dc8, 0x16), at 0xfed417ac
  [5] abort(0xfecb38f0, 0x5b, 0xfecbb514, 0xfecb7608, 0x102, 0x970831), at
0xfec39400
=>[6] JS_Assert(s = 0xff2eb334 "me == CurrentThreadId()", file = 0xff2eb34c
"/cs/src/mozilla/mozilla/js/src/jslock.c", ln = 258), line 146 in "jsutil.c"
  [7] js_GetSlotWhileLocked(cx = 0x84f9c0, obj = 0x7cc480, slot = 2U), line 258
in "jslock.c"
  [8] JS_GetPrivate(cx = 0x84f9c0, obj = 0x7cc480), line 1325 in "jsapi.c"
  [9] nsJSContext::GetGlobalObject(this = 0x29cb70), line 252 in
"nsJSEnvironment.cpp"
  [10] nsJSContext::EvaluateString(this = 0x29cb70, aScript = CLASS, jsObj =
0x7cc480, principal = (nil), aURL = (nil), aLineNo = 0, aRetValue = CLASS,
aIsUndefined = 0xfd9236b8), line 159 in "nsJSEnvironment.cpp"
  [11] nsJSInputStream::Eval(this = 0x91beb0), line 163 in
"nsJSProtocolHandler.cpp"
  [12] nsJSInputStream::Available(this = 0x91beb0, _retval = 0xfd923b2c), line
105 in "nsJSProtocolHandler.cpp"
  [13] nsFileTransport::Process(this = 0xb09c18), line 503 in
"nsFileTransport.cpp"
  [14] nsFileTransport::Run(this = 0xb09c18), line 417 in "nsFileTransport.cpp"
  [15] nsThreadPoolRunnable::Run(this = 0x179190), line 590 in "nsThread.cpp"
  [16] nsThread::Main(arg = 0xdf7d8), line 79 in "nsThread.cpp"
  [17] _pt_root(arg = 0x17a788), line 158 in "ptthread.c"

Updated

19 years ago
Assignee: mccabe → rogerl

Comment 1

19 years ago
Roger, can you handle this?

I'm guessing it's a handoff to some... necko code?  that's handling js and
threads improperly.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
it's that 'javascript:' bug.

*** This bug has been marked as a duplicate of 14049 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
verified duplicate of 14049
You need to log in before you can comment on or make changes to this bug.