Closed Bug 1565138 Opened 5 months ago Closed 5 months ago

Aero glass border flickers frequently, when interacting with the browser UI

Categories

(Core :: Web Painting, defect)

69 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1562184

People

(Reporter: scook0+bugzilla, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

  • Update to Firefox 69
  • Make sure the browser window is not maximised
  • Interact with the browser UI (open a tab, switch tabs, hover over a tab, hover over the URL bar, open the menu, etc.)

Actual results:

Part of the window's Aero glass border flickers during the UI interaction, and then stops flickering shortly after.

Expected results:

The Aero glass border should remain stable, and not flicker.

Attached image flicker-off.png
Attached image flicker-on.png

The exact effect is hard to describe, but it's very obvious (and disruptive) in practice.

After immediately running into this issue on my main profile, I created a fresh profile and reproduced the issue there as well.

Turning on gfx.webrender.all (and restarting the browser) seems to get rid of the flashing, and turning it back off (and restarting) restores the flashing.

So there appears to be some kind of problem in the non-WebRender UI painting.

hi, thank you for the report - i think it's the same issue that's getting investigated in bug 1562184, so i'll dupe it over.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1562184
Component: Untriaged → Web Painting
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.