Limiting searching to whole words only

RESOLVED DUPLICATE of bug 269442

Status

SeaMonkey
Search
--
enhancement
RESOLVED DUPLICATE of bug 269442
15 years ago
3 years ago

People

(Reporter: TGOS, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
What I *really* miss in Mozilla is the ability to search for "words" only. Find
has three options:

[_] Match upper/lower case
[_] Wrap around
[_] Search backwards

IE has no wrap around, it always searches that way and I actually always search
that way as well, so I consider it a stupid option that should be enabled by
default, but that's another bug. What I miss is the other option IE has that
limits seasrching to whole words.

E.g. go to http://java.sun.com/j2se/1.4/docs/api/index.html and now find the
class named "File" in the lower-left frame. If you search for "File" and turn on
"Match upper/lower case" you will get 

AudioFileFormat
AudioFileFormat.Type 
AudioFileReader
AudioFileWriter 
BasicFileChooserUI 
File 

Actually that's still a graceful example. In IE I hit search only *once*,
because I can limit the result to whole words only. If I do that and search for
"File", IE will search for:

_File_

Whereby _ can either be '\n' or '\r' or ' ' (a space). This way I won't find
words "inside of other words".
-> search
Component: XP Apps → Search
QA Contact: paw → claudius

Comment 2

15 years ago
Dupe of:

http://bugzilla.mozilla.org/show_bug.cgi?id=14871

Comment 3

15 years ago
Good work, amutch.

*** This bug has been marked as a duplicate of 14871 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
Duplicate of bug: 269442
You need to log in before you can comment on or make changes to this bug.