Closed Bug 1565410 Opened 5 months ago Closed 5 months ago

[api] Don't expose BundleEventListener

Categories

(GeckoView :: General, defect, P3)

Unspecified
All
defect

Tracking

(firefox69 wontfix, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: Agi, Assigned: Agi)

References

(Regression)

Details

Attachments

(1 file)

Bug 1539144 added WebExtensionController which implements BundleEventListener. Since BundleEventListener is a private class we should not expose it in the API.

This should have been caught by apilint but wasn't, bug for this is at https://github.com/mozilla-mobile/gradle-apilint/issues/62 (fixed in 0.2.2)

Assignee: nobody → agi

This also updates apilint to 0.2.2 to ensure that future instances of this
problem will be caught automatically.

Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d35d90d0322b
Don't expose BundleEventListener in the API. r=esawin
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

This bug was backed out due to conflicts while backing out bug 1557096.
Backout link: https://hg.mozilla.org/mozilla-central/rev/0fb761cd8fa448eb511e8b2520ede5a3230853ed

Status: RESOLVED → REOPENED
Flags: needinfo?(agi)
Resolution: FIXED → ---
Target Milestone: mozilla70 → ---
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2180268af1d
Don't expose BundleEventListener in the API. r=esawin
Flags: needinfo?(agi)
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

69=wontfix because we don't need to uplift this API fix to GV 69 Beta.

You need to log in before you can comment on or make changes to this bug.