Closed Bug 1565563 Opened Last month Closed Last month

test en-US in addition to all-locales

Categories

(Firefox :: Search, defect)

68 Branch
defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox-esr68 --- fixed
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: daleharvey, Assigned: daleharvey)

References

Details

Attachments

(1 file, 1 obsolete file)

We use https://searchfox.org/mozilla-central/source/browser/locales/all-locales to test the SearchService in all locales, however its missing some important ones, specifically "en-US". If we add that locale manually tests fail

After discussion on IRC, its missing en-US since thats the default locale

Assignee: nobody → dharvey
Summary: all-locales is missing a bunch of locales → all-locales is missing en-US

Resummarizing to make it more clear that all-locales actually is doing what it's intended to do, and that the search service tests needs more.

Summary: all-locales is missing en-US → test en-US in addition to all-locales
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5de764b97e6c
Add en-US to search configurations to test. r=Standard8,mconnor

Backed out for causing perma fails on test_validate_engines.js

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=success%2Cpending%2Crunning%2Ctestfailed%2Cbusted%2Cexception&classifiedState=unclassified&searchStr=linux%2Cx64%2Cdebug%2Cxpcshell%2Ctests%2Ctest-linux64%2Fdebug-xpcshell-e10s-6%2Cx%28x6%29&revision=2bd7c693a493af1a8e210effcc3aa196be504f64&selectedJob=256276637

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=256276637&repo=autoland&lineNumber=2641

[task 2019-07-12T22:26:08.795Z] 22:26:08 INFO - TEST-START | toolkit/components/search/tests/xpcshell/test_validate_engines.js
[task 2019-07-12T22:31:08.796Z] 22:31:08 WARNING - TEST-UNEXPECTED-TIMEOUT | toolkit/components/search/tests/xpcshell/test_validate_engines.js | Test timed out
[task 2019-07-12T22:31:08.797Z] 22:31:08 INFO - TEST-INFO took 300000ms
[task 2019-07-12T22:31:08.797Z] 22:31:08 INFO - >>>>>>>
[task 2019-07-12T22:31:08.798Z] 22:31:08 INFO - PID 18621 | WARN 2019-07-12T22:26:08Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-07-12T22:31:08.798Z] 22:31:08 INFO - PID 18621 | [18621, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2555
[task 2019-07-12T22:31:08.803Z] 22:31:08 INFO - PID 18621 | [18621, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, kKnownEsrVersion) failed with result 0x80004002: file /builds/worker/workspace/build/src/toolkit/components/resistfingerprinting/nsRFPService.cpp, line 662
[task 2019-07-12T22:31:08.805Z] 22:31:08 INFO - PID 18621 | [18621, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/worker/workspace/build/src/extensions/permissions/nsPermissionManager.cpp, line 2903
[task 2019-07-12T22:31:08.807Z] 22:31:08 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-07-12T22:31:08.808Z] 22:31:08 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-07-12T22:31:08.810Z] 22:31:08 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-07-12T22:31:08.812Z] 22:31:08 INFO - running event loop
[task 2019-07-12T22:31:08.814Z] 22:31:08 INFO - toolkit/components/search/tests/xpcshell/test_validate_engines.js | Starting setup
[task 2019-07-12T22:31:08.815Z] 22:31:08 INFO - (xpcshell/head.js) | test setup pending (2)
[task 2019-07-12T22:31:08.816Z] 22:31:08 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-07-12T22:31:08.817Z] 22:31:08 INFO - PID 18621 | 1562970369255 addons.xpi WARN List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: startup :: line 2384" data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm:2384
[task 2019-07-12T22:31:08.821Z] 22:31:08 INFO - PID 18621 | callProvider()@resource://gre/modules/AddonManager.jsm:213
[task 2019-07-12T22:31:08.822Z] 22:31:08 INFO - PID 18621 | _startProvider()@resource://gre/modules/AddonManager.jsm:649
[task 2019-07-12T22:31:08.823Z] 22:31:08 INFO - PID 18621 | startup()@resource://gre/modules/AddonManager.jsm:873
[task 2019-07-12T22:31:08.828Z] 22:31:08 INFO - PID 18621 | startup()@resource://gre/modules/AddonManager.jsm:3465
[task 2019-07-12T22:31:08.829Z] 22:31:08 INFO - PID 18621 | observe()@resource://gre/modules/addonManager.js:86
[task 2019-07-12T22:31:08.830Z] 22:31:08 INFO - PID 18621 | promiseStartupManager()@resource://testing-common/AddonTestUtils.jsm:980
[task 2019-07-12T22:31:08.832Z] 22:31:08 INFO - PID 18621 | setup()@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_validate_engines.js:48
[task 2019-07-12T22:31:08.833Z] 22:31:08 INFO - "CONSOLE_MESSAGE: (info) 1562970369255 addons.xpi WARN List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: startup :: line 2384" data: no] Stack trace: startup()@resource://gre/modules/addons/XPIProvider.jsm:2384
[task 2019-07-12T22:31:08.839Z] 22:31:08 INFO - callProvider()@resource://gre/modules/AddonManager.jsm:213
[task 2019-07-12T22:31:08.840Z] 22:31:08 INFO - _startProvider()@resource://gre/modules/AddonManager.jsm:649
[task 2019-07-12T22:31:08.841Z] 22:31:08 INFO - startup()@resource://gre/modules/AddonManager.jsm:873
[task 2019-07-12T22:31:08.842Z] 22:31:08 INFO - startup()@resource://gre/modules/AddonManager.jsm:3465
[task 2019-07-12T22:31:08.844Z] 22:31:08 INFO - observe()@resource://gre/modules/addonManager.js:86
[task 2019-07-12T22:31:08.845Z] 22:31:08 INFO - promiseStartupManager()@resource://testing-common/AddonTestUtils.jsm:980
[task 2019-07-12T22:31:08.846Z] 22:31:08 INFO - setup()@/builds/worker/workspace/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_validate_engines.js:48"
[task 2019-07-12T22:31:08.847Z] 22:31:08 INFO - PID 18621 | [18621, GMPThread] WARNING: Failed to delete GMP storage directory: file /builds/worker/workspace/build/src/dom/media/gmp/GMPServiceParent.cpp, line 1571
[task 2019-07-12T22:31:08.848Z] 22:31:08 INFO - (xpcshell/head.js) | test run_next_test 1 pending (2)
[task 2019-07-12T22:31:08.850Z] 22:31:08 INFO - (xpcshell/head.js) | test setup finished (2)
[task 2019-07-12T22:31:08.850Z] 22:31:08 INFO - toolkit/components/search/tests/xpcshell/test_validate_engines.js | Starting test_validate_engines
[task 2019-07-12T22:31:08.856Z] 22:31:08 INFO - (xpcshell/head.js) | test test_validate_engines pending (2)
[task 2019-07-12T22:31:08.857Z] 22:31:08 INFO - (xpcshell/head.js) | test run_next_test 1 finished (2)

Backout: https://hg.mozilla.org/integration/autoland/rev/bdbad45678f3de463e12cc9ab60fdec749abb7b5

Flags: needinfo?(dharvey)
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/630e5bec018b
Add en-US to search configurations to test. r=Standard8,mconnor
Attachment #9077913 - Attachment is obsolete: true

Yeh the subsequent test had a test issue, relanded, thanks

Flags: needinfo?(dharvey)
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

https://hg.mozilla.org/releases/mozilla-beta/rev/302bea2b4bfdd98563a937263dbb659fe7952d07

Please check this into mozilla-release and mozilla-esr68 as well (a=test-only)

Iteration: --- → 70.1 - Jul 8 - 21
Points: --- → 2
You need to log in before you can comment on or make changes to this bug.