Closed Bug 1565786 Opened 1 year ago Closed 10 months ago

[Fission] Embedded youtube video is white out after switching to other tab

Categories

(Core :: Graphics, defect, P3)

Desktop
Unspecified
defect

Tracking

()

RESOLVED FIXED
Fission Milestone M5

People

(Reporter: github, Assigned: hiro)

References

(Blocks 2 open bugs)

Details

(Keywords: nightly-community)

Not sure about this is the right component. Steps to reproduce:

  1. Open http://www.nashcountrydaily.com/2019/07/12/chris-young-lauren-alaina-team-up-for-breakup-anthem-town-aint-big-enough-listen/
  2. Make sure the youtube video is loaded (no interaction needed)
  3. Switch to a different tab for a couple seconds, interact with it maybe
  4. Switch back to the other tab

Now the video is just white out, background audio still works fine. Webrender is active.

I believe this is caused by the same reason of bug 1562562.

Summary: Embedded youtube video is white out after switching to other tab → [Fission] Embedded youtube video is white out after switching to other tab
Priority: -- → P3
Fission Milestone: --- → M5
See Also: → 1562562

This seems to happen with more than just YouTube embeds.
For example:
Open up https://rateyourmusic.com/release/album/gojira/from-mars-to-sirius/
Note the Bandcamp embed on the left.
Switch Tabs
The frame disappears.

And it also happens when using the back button:
Open up https://rateyourmusic.com/release/album/gojira/from-mars-to-sirius/
Note the Bandcamp embed on the left.
Click a link
Hit the back button
The frame fails to load.

I've also experienced this with Disqus comments, Giffycat, Streamable, etc.

Duplicate of this bug: 1586519
See Also: → 1594535
See Also: 1594535
Duplicate of this bug: 1598222

I believe this will also be fixed by bug 1550800.

Assignee: nobody → hikezoe.birchill
Blocks: 1550800
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: 1562562
Duplicate of this bug: 1562562
No longer blocks: 1550800
Depends on: 1550800

Fixed by bug 1550800.

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.