Closed Bug 1565816 Opened 5 months ago Closed 5 months ago

[Protections Panel] Implement the new animation on the shield icon

Categories

(Firefox :: Site Identity, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: timhuang, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [skyline])

Attachments

(7 files)

There is a new animation for the shield icon if there is any tracker been blocked.

Tim, just double checking, is this part of Skyline?

Flags: needinfo?(tihuang)
Whiteboard: [skyline]

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #1)

Tim, just double checking, is this part of Skyline?

Yes, I believe so.

Flags: needinfo?(tihuang)
Assignee: nobody → tihuang
Status: NEW → ASSIGNED

This patch modifies the old animation CSS rules to match the new
animation.

Depends on D39175

This patch makes the tracking protection icon to show the last frame of
the shield animation when there is a blocking happening and the
animation is disabled.

Depends on D39176

This patch add a css rule to apply a 'scaleX(-1)' tranform to the
tracking protection icon in order to show a correct direction of the
tracking protection icon in rtl mode.

Depends on D39177

Applied some optimizations:

  • Remove redundant 100%/100% style attributes
  • Remove redundant xmlns and user-select attributes
  • Use reference to single shared gradient
  • Use reference to shared path definitions

Remove redundant 100%/100% style attributes
Remove redundant xmlns and user-select attributes
Use reference to single shared gradient
Use reference to shared path definitions

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22d335ceae8c
Part 1: Update the shield animation to the new version. r=johannh,sfoster
https://hg.mozilla.org/integration/autoland/rev/5369e35b9f98
Part 2: Modify the animation for the new animation. r=johannh
https://hg.mozilla.org/integration/autoland/rev/1308d4cee5a2
Part 3: Show the last frame of the animation icon if the animation is disabled and there is a blocking happening. r=johannh
https://hg.mozilla.org/integration/autoland/rev/81d5b8653725
Part 4: Apply a transform to tracking protection icon in order to show a correct direction of the tracking protectoin icon in rtl mode. r=johannh
https://hg.mozilla.org/integration/autoland/rev/f8b41be3e8c2
Part 5: Update the test browser_trackingUI_animation.js. r=johannh
Duplicate of this bug: 1565815
Flags: qe-verify+

I can confirm the shield animation is updated. I verified using Fx 70.0b5 on Windows 10 x64, Ubuntu 18.04 and macOS 10.5 beta7.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1591049
You need to log in before you can comment on or make changes to this bug.