Closed Bug 1565925 Opened 2 years ago Closed 2 years ago

1st leading or trailing # character dropped from search

Categories

(Firefox :: Address Bar, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1560228

People

(Reporter: lizardswimmer, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

In the address bar, enter a search with a single or multiple # (ASCII 35) characters at the beginning or end of the search. It doesn't seem to matter if there's a space between the other search content or not. Tried this with Google, Bing, DuckDuckGo. Also tried with add-ons disabled.

Actual results:

It seems like only 1 # character is ever dropped from the search. When there's other content surrounding the # character it isn't dropped.
"#test" -> "test"
"test#" -> "test"
"test##" -> "test#"
"test###" -> "test##"
"#test#" -> "test#"
" #test" -> "test"

"test # test" -> "test # test"

Expected results:

Expected the # character to stay in the search regardless of positioning or other # characters

Seems duplication of Bug 1560228

Component: Untriaged → Address Bar
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1560228
You need to log in before you can comment on or make changes to this bug.