Closed Bug 1566000 Opened 1 year ago Closed 1 year ago

Extensions installed in permanent private browsing mode do not work by default

Categories

(WebExtensions :: General, defect)

67 Branch
defect
Not set

Tracking

(firefox-esr68 wontfix, firefox68 wontfix, firefox69 wontfix, firefox70 wontfix)

RESOLVED INVALID
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

STR:

  1. Enable permanent private browsing mode (PBM) by choosing Never remember history (browser.privatebrowsing.autostart = true).
  2. Install an extension.

Expected:

The extension is available — button is visible in toolbar, preferences tab appears etc.

Actual:

The extension is listed as enabled but is unavailable, have to go into extension settings and allow in private windows to get it working. Since all windows are treated as private windows in PBM, this extra step is unnecessary and serves no purpose other than to cause confusion.

Workaround is to set extensions.allowPrivateBrowsingByDefault = true.

A post-install panel allows the user to check the private browsing option during the install flow. Access is intentionally denied unless the user explicitly gives permission.

allowPrivateBrowsingByDefault will be removed in a future version and should not be suggested as a workaround.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
Version: Firefox 67 → 67 Branch
You need to log in before you can comment on or make changes to this bug.