Closed Bug 1566371 Opened 5 months ago Closed 4 months ago

Create a memory distribution metric type in glean-core

Categories

(Data Platform and Tools :: Glean: SDK, task, P1)

task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Dexter, Assigned: janerik)

References

(Blocks 1 open bug)

Details

(Whiteboard: [telemetry:glean-rs:m8] [geckoview:fenix:m8])

Attachments

(1 file)

Some Gecko metrics do not map to Timing Distributions, but are rather Memory Distributions (see MEMORY_* histograms in this spreadsheet). This bug is for designing and implementing a MemoryDistributionMetricType for the Glean SDK, to support the memory related use-cases.

Blocks: 1566340
Depends on: 1566368
Priority: -- → P3
Whiteboard: [telemetry:glean-rs:m?]
Whiteboard: [telemetry:glean-rs:m?] → [telemetry:glean-rs:m7][geckoview]
Whiteboard: [telemetry:glean-rs:m7][geckoview] → [telemetry:glean-rs:m7] [geckoview:fenix:m8]
Summary: Create a memory distribution metric type in the Glean SDK → Create a memory distribution metric type in glean-core
Whiteboard: [telemetry:glean-rs:m7] [geckoview:fenix:m8] → [telemetry:glean-rs:m8] [geckoview:fenix:m8]
Assignee: nobody → jrediger
Priority: P3 → P1
Attached file GitHub Pull Request
Duplicate of this bug: 1573442
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.